diff options
Diffstat (limited to 'Makefile.PL')
-rw-r--r-- | Makefile.PL | 45 |
1 files changed, 23 insertions, 22 deletions
diff --git a/Makefile.PL b/Makefile.PL index c043edb..d1f0c2a 100644 --- a/Makefile.PL +++ b/Makefile.PL | |||
@@ -1,22 +1,23 @@ | |||
1 | use 5.006; | 1 | use inc::Module::Install; |
2 | use ExtUtils::MakeMaker; | 2 | |
3 | # See lib/ExtUtils/MakeMaker.pm for details of how to influence | 3 | name 'Monitoring-Plugin'; |
4 | # the contents of the Makefile that is written. | 4 | all_from 'lib/Monitoring/Plugin/Functions.pm'; |
5 | WriteMakefile( | 5 | author q{Monitoring Plugin Team <devel@monitoring-plugins.org>}; |
6 | NAME => 'Nagios::Plugin', | 6 | license 'perl'; |
7 | VERSION_FROM => 'lib/Nagios/Plugin/Functions.pm', # finds $VERSION | 7 | repository 'https://github.com/monitoring-plugins/monitoring-plugin-perl'; |
8 | PREREQ_PM => { | 8 | |
9 | Params::Validate => 0, | 9 | requires 'Params::Validate' => 0; |
10 | Class::Accessor => 0, | 10 | requires 'Class::Accessor' => 0; |
11 | Test::More => 0.62, | 11 | requires 'Carp' => 0; |
12 | Carp => 0, | 12 | requires 'Config::Tiny' => 0; |
13 | Config::Tiny => 0, | 13 | requires 'File::Spec' => 0; |
14 | File::Spec => 0, | 14 | requires 'File::Basename' => 0; |
15 | File::Basename => 0, | 15 | requires 'IO::File' => 0; |
16 | IO::File => 0, | 16 | requires 'Math::Calc::Units' => 0; # used in M::P::Performance |
17 | Math::Calc::Units => 0, # used in N::P::Performance | 17 | |
18 | }, # e.g., Module::Name => 1.1 | 18 | |
19 | ($] >= 5.005 ? ## Add these new keywords supported since 5.005 | 19 | build_requires 'Test::More' => 0.62; |
20 | (ABSTRACT_FROM => 'lib/Nagios/Plugin.pm', # retrieve abstract from module | 20 | |
21 | AUTHOR => 'Nagios Plugin Development Team <nagiosplug-devel@lists.sourceforge.net>') : ()), | 21 | auto_install; |
22 | ); | 22 | |
23 | WriteAll; | ||