diff options
author | Lorenz Kästle <12514511+RincewindsHat@users.noreply.github.com> | 2025-02-19 14:23:54 +0100 |
---|---|---|
committer | Lorenz Kästle <12514511+RincewindsHat@users.noreply.github.com> | 2025-02-19 14:23:54 +0100 |
commit | bd2611685f28f877e1f2b01ec2af3435c56d836f (patch) | |
tree | b0347ef72a21dec3e4a05a045d41f752ba0d1519 /configure.ac | |
parent | ec18b80cdbdc2c4c1e7eb587e251177e8cc7ca11 (diff) | |
parent | e23325f7c3b34d8950cf27e9ab23af362d0b341b (diff) | |
download | monitoring-plugins-bd2611685f28f877e1f2b01ec2af3435c56d836f.tar.gz |
Merge branch 'master' into feature/new_output_infra
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 97 |
1 files changed, 35 insertions, 62 deletions
diff --git a/configure.ac b/configure.ac index b12cf6c5..e9254566 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,6 +1,6 @@ | |||
1 | dnl Process this file with autoconf to produce a configure script. | 1 | dnl Process this file with autoconf to produce a configure script. |
2 | AC_PREREQ(2.64) | 2 | AC_PREREQ([2.64]) |
3 | AC_INIT(monitoring-plugins,2.4git) | 3 | AC_INIT([monitoring-plugins],[2.4git]) |
4 | AC_CONFIG_SRCDIR(NPTest.pm) | 4 | AC_CONFIG_SRCDIR(NPTest.pm) |
5 | AC_CONFIG_FILES([gl/Makefile]) | 5 | AC_CONFIG_FILES([gl/Makefile]) |
6 | AC_CONFIG_AUX_DIR(build-aux) | 6 | AC_CONFIG_AUX_DIR(build-aux) |
@@ -43,14 +43,14 @@ AC_SUBST(INSTALL) | |||
43 | AC_PROG_CC | 43 | AC_PROG_CC |
44 | gl_EARLY | 44 | gl_EARLY |
45 | AC_PROG_GCC_TRADITIONAL | 45 | AC_PROG_GCC_TRADITIONAL |
46 | AC_PROG_LIBTOOL | 46 | LT_INIT |
47 | 47 | ||
48 | AM_PROG_CC_C_O | 48 | AM_PROG_CC_C_O |
49 | 49 | ||
50 | AC_FUNC_ERROR_AT_LINE | 50 | AC_FUNC_ERROR_AT_LINE |
51 | AC_SYS_LARGEFILE | 51 | AC_SYS_LARGEFILE |
52 | 52 | ||
53 | ifdef([AC_FUNC_STRTOD],[AC_FUNC_STRTOD],[AM_FUNC_STRTOD]) | 53 | ifdef([AC_FUNC_STRTOD],[AC_FUNC_STRTOD],[AC_FUNC_STRTOD]) |
54 | 54 | ||
55 | PLUGIN_TEST=`echo $srcdir/plugins/t/*.t|sed -e 's,\.*/plugins/,,g'` | 55 | PLUGIN_TEST=`echo $srcdir/plugins/t/*.t|sed -e 's,\.*/plugins/,,g'` |
56 | AC_SUBST(PLUGIN_TEST)dnl | 56 | AC_SUBST(PLUGIN_TEST)dnl |
@@ -125,8 +125,7 @@ AC_SUBST(PERL, $with_perl) | |||
125 | 125 | ||
126 | dnl openssl/gnutls | 126 | dnl openssl/gnutls |
127 | AC_ARG_WITH(openssl, | 127 | AC_ARG_WITH(openssl, |
128 | AC_HELP_STRING([--with-openssl=DIR], | 128 | AS_HELP_STRING([--with-openssl=DIR],[path to openssl installation]),) |
129 | [path to openssl installation]),) | ||
130 | 129 | ||
131 | AC_ARG_WITH(gnutls, | 130 | AC_ARG_WITH(gnutls, |
132 | ACX_HELP_STRING([--with-gnutls=PATH], | 131 | ACX_HELP_STRING([--with-gnutls=PATH], |
@@ -167,8 +166,7 @@ AC_SUBST(MATHLIBS) | |||
167 | 166 | ||
168 | dnl Check if we buils local libtap | 167 | dnl Check if we buils local libtap |
169 | AC_ARG_ENABLE(libtap, | 168 | AC_ARG_ENABLE(libtap, |
170 | AC_HELP_STRING([--enable-libtap], | 169 | AS_HELP_STRING([--enable-libtap],[Enable built-in libtap for unit-testing (default: autodetect system library).]), |
171 | [Enable built-in libtap for unit-testing (default: autodetect system library).]), | ||
172 | [enable_libtap=$enableval], | 170 | [enable_libtap=$enableval], |
173 | [enable_libtap=no]) | 171 | [enable_libtap=no]) |
174 | AM_CONDITIONAL([USE_LIBTAP_LOCAL],[test "$enable_libtap" = "yes"]) | 172 | AM_CONDITIONAL([USE_LIBTAP_LOCAL],[test "$enable_libtap" = "yes"]) |
@@ -205,8 +203,7 @@ AM_CONDITIONAL([ENALBE_JSON_OUTPUT], [test x$json_output = xtrue]) | |||
205 | 203 | ||
206 | dnl INI Parsing | 204 | dnl INI Parsing |
207 | AC_ARG_ENABLE(extra-opts, | 205 | AC_ARG_ENABLE(extra-opts, |
208 | AC_HELP_STRING([--enable-extra-opts], | 206 | AS_HELP_STRING([--enable-extra-opts],[Enables parsing of plugins ini config files for extra options (default: no)]), |
209 | [Enables parsing of plugins ini config files for extra options (default: no)]), | ||
210 | [enable_extra_opts=$enableval], | 207 | [enable_extra_opts=$enableval], |
211 | [enable_extra_opts=yes]) | 208 | [enable_extra_opts=yes]) |
212 | AM_CONDITIONAL([USE_PARSE_INI],[test "$enable_extra_opts" = "yes"]) | 209 | AM_CONDITIONAL([USE_PARSE_INI],[test "$enable_extra_opts" = "yes"]) |
@@ -480,20 +477,16 @@ AC_ARG_WITH([ipv6], | |||
480 | dnl Check for AF_INET6 support - unistd.h required for Darwin | 477 | dnl Check for AF_INET6 support - unistd.h required for Darwin |
481 | if test "$with_ipv6" != "no"; then | 478 | if test "$with_ipv6" != "no"; then |
482 | AC_CACHE_CHECK([for IPv6 support], np_cv_sys_ipv6, [ | 479 | AC_CACHE_CHECK([for IPv6 support], np_cv_sys_ipv6, [ |
483 | AC_TRY_COMPILE( | 480 | AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#ifdef HAVE_UNISTD_H |
484 | [#ifdef HAVE_UNISTD_H | ||
485 | #include <unistd.h> | 481 | #include <unistd.h> |
486 | #endif | 482 | #endif |
487 | #include <netinet/in.h> | 483 | #include <netinet/in.h> |
488 | #include <sys/socket.h>], | 484 | #include <sys/socket.h>]], [[struct sockaddr_in6 sin6; |
489 | [struct sockaddr_in6 sin6; | ||
490 | void *p; | 485 | void *p; |
491 | 486 | ||
492 | sin6.sin6_family = AF_INET6; | 487 | sin6.sin6_family = AF_INET6; |
493 | sin6.sin6_port = 587; | 488 | sin6.sin6_port = 587; |
494 | p = &sin6.sin6_addr;], | 489 | p = &sin6.sin6_addr;]])],[np_cv_sys_ipv6=yes],[np_cv_sys_ipv6=no]) |
495 | [np_cv_sys_ipv6=yes], | ||
496 | [np_cv_sys_ipv6=no]) | ||
497 | ]) | 490 | ]) |
498 | if test "$np_cv_sys_ipv6" = "no" -a "$with_ipv6" != "check"; then | 491 | if test "$np_cv_sys_ipv6" = "no" -a "$with_ipv6" != "check"; then |
499 | AC_MSG_FAILURE([--with-ipv6 was given, but test for IPv6 support failed]) | 492 | AC_MSG_FAILURE([--with-ipv6 was given, but test for IPv6 support failed]) |
@@ -627,10 +620,10 @@ dnl | |||
627 | dnl Checks for header files. | 620 | dnl Checks for header files. |
628 | dnl | 621 | dnl |
629 | 622 | ||
630 | AC_HEADER_TIME | ||
631 | AC_HEADER_SYS_WAIT | 623 | AC_HEADER_SYS_WAIT |
632 | AC_CHECK_HEADERS(signal.h syslog.h uio.h errno.h sys/time.h sys/socket.h sys/un.h sys/poll.h) | 624 | AC_CHECK_HEADERS(signal.h syslog.h uio.h errno.h sys/time.h sys/socket.h sys/un.h sys/poll.h) |
633 | AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h) | 625 | AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h) |
626 | AC_CHECK_HEADERS_ONCE([sys/time.h]) | ||
634 | 627 | ||
635 | dnl Checks for typedefs, structures, and compiler characteristics. | 628 | dnl Checks for typedefs, structures, and compiler characteristics. |
636 | AC_C_CONST | 629 | AC_C_CONST |
@@ -639,36 +632,27 @@ AC_TYPE_PID_T | |||
639 | AC_TYPE_SIZE_T | 632 | AC_TYPE_SIZE_T |
640 | 633 | ||
641 | AC_CACHE_CHECK([for va_copy],ac_cv_HAVE_VA_COPY,[ | 634 | AC_CACHE_CHECK([for va_copy],ac_cv_HAVE_VA_COPY,[ |
642 | AC_TRY_LINK([#include <stdarg.h> | 635 | AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <stdarg.h> |
643 | va_list ap1,ap2;], [va_copy(ap1,ap2);], | 636 | va_list ap1,ap2;]], [[va_copy(ap1,ap2);]])],[ac_cv_HAVE_VA_COPY=yes],[ac_cv_HAVE_VA_COPY=no])]) |
644 | ac_cv_HAVE_VA_COPY=yes, | ||
645 | ac_cv_HAVE_VA_COPY=no)]) | ||
646 | if test x"$ac_cv_HAVE_VA_COPY" = x"yes"; then | 637 | if test x"$ac_cv_HAVE_VA_COPY" = x"yes"; then |
647 | AC_DEFINE(HAVE_VA_COPY,1,[Whether va_copy() is available]) | 638 | AC_DEFINE(HAVE_VA_COPY,1,[Whether va_copy() is available]) |
648 | else | 639 | else |
649 | AC_CACHE_CHECK([for __va_copy],ac_cv_HAVE___VA_COPY,[ | 640 | AC_CACHE_CHECK([for __va_copy],ac_cv_HAVE___VA_COPY,[ |
650 | AC_TRY_LINK([#include <stdarg.h> | 641 | AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <stdarg.h> |
651 | va_list ap1,ap2;], [__va_copy(ap1,ap2);], | 642 | va_list ap1,ap2;]], [[__va_copy(ap1,ap2);]])],[ac_cv_HAVE___VA_COPY=yes],[ac_cv_HAVE___VA_COPY=no])]) |
652 | ac_cv_HAVE___VA_COPY=yes, | ||
653 | ac_cv_HAVE___VA_COPY=no)]) | ||
654 | if test x"$ac_cv_HAVE___VA_COPY" = x"yes"; then | 643 | if test x"$ac_cv_HAVE___VA_COPY" = x"yes"; then |
655 | AC_DEFINE(HAVE___VA_COPY,1,[Whether __va_copy() is available]) | 644 | AC_DEFINE(HAVE___VA_COPY,1,[Whether __va_copy() is available]) |
656 | fi | 645 | fi |
657 | fi | 646 | fi |
658 | 647 | ||
659 | AC_TRY_COMPILE([#include <sys/time.h>], | 648 | AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/time.h>]], [[struct timeval *tv; |
660 | [struct timeval *tv; | 649 | struct timezone *tz;]])],[AC_DEFINE(HAVE_STRUCT_TIMEVAL,1,Define if we have a timeval structure) |
661 | struct timezone *tz;], | 650 | FOUND_STRUCT_TIMEVAL="yes"],[]) |
662 | AC_DEFINE(HAVE_STRUCT_TIMEVAL,1,[Define if we have a timeval structure]) | ||
663 | FOUND_STRUCT_TIMEVAL="yes") | ||
664 | 651 | ||
665 | if test x"$FOUND_STRUCT_TIMEVAL" = x"yes"; then | 652 | if test x"$FOUND_STRUCT_TIMEVAL" = x"yes"; then |
666 | AC_TRY_COMPILE([#include <sys/time.h>], | 653 | AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/time.h>]], [[struct timeval *tv; |
667 | [struct timeval *tv; | ||
668 | struct timezone *tz; | 654 | struct timezone *tz; |
669 | gettimeofday(tv, tz);], | 655 | gettimeofday(tv, tz);]])],[AC_DEFINE(HAVE_GETTIMEOFDAY,1,Define if gettimeofday is found)],[AC_DEFINE(NEED_GETTIMEOFDAY,1,Define if gettimeofday is needed)]) |
670 | AC_DEFINE(HAVE_GETTIMEOFDAY,1,[Define if gettimeofday is found]), | ||
671 | AC_DEFINE(NEED_GETTIMEOFDAY,1,[Define if gettimeofday is needed])) | ||
672 | fi | 656 | fi |
673 | 657 | ||
674 | dnl Checks for library functions. | 658 | dnl Checks for library functions. |
@@ -676,14 +660,11 @@ AC_CHECK_FUNCS(memmove select socket strdup strstr strtol strtoul floor) | |||
676 | AC_CHECK_FUNCS(poll) | 660 | AC_CHECK_FUNCS(poll) |
677 | 661 | ||
678 | AC_MSG_CHECKING(return type of socket size) | 662 | AC_MSG_CHECKING(return type of socket size) |
679 | AC_TRY_COMPILE([#include <stdlib.h> | 663 | AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdlib.h> |
680 | #include <sys/types.h> | 664 | #include <sys/types.h> |
681 | #include <sys/socket.h>], | 665 | #include <sys/socket.h>]], [[int a = send(1, (const void *) buffer, (size_t *) 0, (int *) 0);]])],[ac_cv_socket_size_type="size_t" |
682 | [int a = send(1, (const void *) buffer, (size_t *) 0, (int *) 0);], | 666 | AC_MSG_RESULT(size_t)],[ac_cv_socket_size_type="int" |
683 | ac_cv_socket_size_type=["size_t"] | 667 | AC_MSG_RESULT(int)]) |
684 | AC_MSG_RESULT(size_t), | ||
685 | ac_cv_socket_size_type=["int"] | ||
686 | AC_MSG_RESULT(int)) | ||
687 | 668 | ||
688 | AC_DEFINE_UNQUOTED(SOCKET_SIZE_TYPE, $ac_cv_socket_size_type , | 669 | AC_DEFINE_UNQUOTED(SOCKET_SIZE_TYPE, $ac_cv_socket_size_type , |
689 | [Define type of socket size]) | 670 | [Define type of socket size]) |
@@ -1446,20 +1427,14 @@ if test -n "$ac_cv_nslookup_command"; then | |||
1446 | fi | 1427 | fi |
1447 | 1428 | ||
1448 | AC_MSG_CHECKING([for number of online cpus]) | 1429 | AC_MSG_CHECKING([for number of online cpus]) |
1449 | AC_TRY_COMPILE([#include <unistd.h>], | 1430 | AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>]], [[sysconf(_SC_NPROCESSORS_ONLN) > 0;]])],[AC_DEFINE(HAVE_SYSCONF__SC_NPROCESSORS_ONLN,1,Define if sysconf returns number of online cpus) |
1450 | [sysconf(_SC_NPROCESSORS_ONLN) > 0;], | 1431 | AC_MSG_RESULT(sysconf(_SC_NPROCESSORS_ONLN))],[AC_MSG_RESULT(cannot calculate) |
1451 | AC_DEFINE(HAVE_SYSCONF__SC_NPROCESSORS_ONLN,1,[Define if sysconf returns number of online cpus]) | 1432 | ]) |
1452 | AC_MSG_RESULT([sysconf(_SC_NPROCESSORS_ONLN)]), | ||
1453 | AC_MSG_RESULT([cannot calculate]) | ||
1454 | ) | ||
1455 | 1433 | ||
1456 | AC_MSG_CHECKING([for number of available cpus]) | 1434 | AC_MSG_CHECKING([for number of available cpus]) |
1457 | AC_TRY_COMPILE([#include <unistd.h>], | 1435 | AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>]], [[sysconf(_SC_NPROCESSORS_CONF) > 0;]])],[AC_DEFINE(HAVE_SYSCONF__SC_NPROCESSORS_CONF,1,Define if sysconf returns number of available cpus) |
1458 | [sysconf(_SC_NPROCESSORS_CONF) > 0;], | 1436 | AC_MSG_RESULT(sysconf(_SC_NPROCESSORS_CONF))],[AC_MSG_RESULT(cannot calculate) |
1459 | AC_DEFINE(HAVE_SYSCONF__SC_NPROCESSORS_CONF,1,[Define if sysconf returns number of available cpus]) | 1437 | ]) |
1460 | AC_MSG_RESULT([sysconf(_SC_NPROCESSORS_CONF)]), | ||
1461 | AC_MSG_RESULT([cannot calculate]) | ||
1462 | ) | ||
1463 | 1438 | ||
1464 | AC_PATH_PROG(PATH_TO_UPTIME,uptime) | 1439 | AC_PATH_PROG(PATH_TO_UPTIME,uptime) |
1465 | AC_ARG_WITH(uptime_command, | 1440 | AC_ARG_WITH(uptime_command, |
@@ -1877,8 +1852,7 @@ dnl We patch plugins/popen.c | |||
1877 | dnl Need to add smp because uname different on those | 1852 | dnl Need to add smp because uname different on those |
1878 | dnl Can force patch to be applied with --enable-redhat-pthread-workaround | 1853 | dnl Can force patch to be applied with --enable-redhat-pthread-workaround |
1879 | AC_ARG_ENABLE(redhat-pthread-workaround, | 1854 | AC_ARG_ENABLE(redhat-pthread-workaround, |
1880 | AC_HELP_STRING([--enable-redhat-pthread-workaround], | 1855 | AS_HELP_STRING([--enable-redhat-pthread-workaround],[force Redhat patch to be applied (default: test system)]), |
1881 | [force Redhat patch to be applied (default: test system)]), | ||
1882 | [ac_cv_enable_redhat_pthread_workaround=$enableval], | 1856 | [ac_cv_enable_redhat_pthread_workaround=$enableval], |
1883 | [ac_cv_enable_redhat_pthread_workaround=test]) | 1857 | [ac_cv_enable_redhat_pthread_workaround=test]) |
1884 | if test "$ac_cv_enable_redhat_pthread_workaround" = "test" ; then | 1858 | if test "$ac_cv_enable_redhat_pthread_workaround" = "test" ; then |
@@ -1899,8 +1873,7 @@ fi | |||
1899 | 1873 | ||
1900 | dnl Perl modules | 1874 | dnl Perl modules |
1901 | AC_ARG_ENABLE(perl-modules, | 1875 | AC_ARG_ENABLE(perl-modules, |
1902 | AC_HELP_STRING([--enable-perl-modules], | 1876 | AS_HELP_STRING([--enable-perl-modules],[Enables installation of Monitoring::Plugin and its dependencies (default: no)]), |
1903 | [Enables installation of Monitoring::Plugin and its dependencies (default: no)]), | ||
1904 | [enable_perl_modules=$enableval], | 1877 | [enable_perl_modules=$enableval], |
1905 | [enable_perl_modules=no]) | 1878 | [enable_perl_modules=no]) |
1906 | if test "$enable_perl_modules" = "yes" ; then | 1879 | if test "$enable_perl_modules" = "yes" ; then |
@@ -1927,8 +1900,7 @@ if test "$ac_cv_uname_s" = 'SunOS' -a \( "x$ac_cv_prog_ac_ct_AR" = "x" -o "$ac_c | |||
1927 | AC_MSG_ERROR(No ar found for Solaris - is /usr/ccs/bin in PATH?) | 1900 | AC_MSG_ERROR(No ar found for Solaris - is /usr/ccs/bin in PATH?) |
1928 | fi | 1901 | fi |
1929 | 1902 | ||
1930 | AC_OUTPUT( | 1903 | AC_CONFIG_FILES([Makefile |
1931 | Makefile | ||
1932 | tap/Makefile | 1904 | tap/Makefile |
1933 | lib/Makefile | 1905 | lib/Makefile |
1934 | plugins/Makefile | 1906 | plugins/Makefile |
@@ -1940,7 +1912,8 @@ AC_OUTPUT( | |||
1940 | perlmods/Makefile | 1912 | perlmods/Makefile |
1941 | test.pl | 1913 | test.pl |
1942 | pkg/solaris/pkginfo | 1914 | pkg/solaris/pkginfo |
1943 | ) | 1915 | ]) |
1916 | AC_OUTPUT | ||
1944 | 1917 | ||
1945 | 1918 | ||
1946 | dnl the ones below that are commented out need to be cleaned up | 1919 | dnl the ones below that are commented out need to be cleaned up |