summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeremy T. Bouse <undrgrid@users.sourceforge.net>2003-03-15 01:25:35 (GMT)
committerJeremy T. Bouse <undrgrid@users.sourceforge.net>2003-03-15 01:25:35 (GMT)
commit11b35b92e3195d230bef359f6a0679ae4414716b (patch)
treef4911e5804c1f3037dcf63bbbf0b823c5ac19e5f /configure.in
parent6cf5fc3c74c0bdfef6c4cc1b627578378ad3a407 (diff)
downloadmonitoring-plugins-11b35b92e3195d230bef359f6a0679ae4414716b.tar.gz
Spent the day working on backwards compatability using getaddrinfo()
Moved getaddrinfo.? and gethostbyname.? from lib/ to plugins/ due to problems with compiling into the libnagiosplug.a as it required linking against socket libraries which are unneeded except for network based plugins. This code should hopefully happily work for all systems and has been tested prior to commit on Debian GNU/Linux, SPARC Solaris 7 and SPARC Solaris 9. git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@424 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ec3606e..eea01da 100644
--- a/configure.in
+++ b/configure.in
@@ -386,7 +386,7 @@ else
386 if test x$enable_emulate_getaddrinfo != xyes ; then 386 if test x$enable_emulate_getaddrinfo != xyes ; then
387 AC_MSG_ERROR([getaddrinfo not found: try --with-lwres or --enable-emulate-getaddrinfo]) 387 AC_MSG_ERROR([getaddrinfo not found: try --with-lwres or --enable-emulate-getaddrinfo])
388 fi 388 fi
389 LIBOBJS="$LIBOBJS getaddrinfo.o" 389 EXTRA_NETOBJS="$EXTRA_NETOBJS getaddrinfo.o"
390fi 390fi
391 391
392if test x"$enable_emulate_getaddrinfo" != xno ; then 392if test x"$enable_emulate_getaddrinfo" != xno ; then
@@ -414,7 +414,8 @@ if test x"$enable_emulate_getaddrinfo" != xno ; then
414 AC_SEARCH_LIBS(gethostbyname, resolv bind nsl, , 414 AC_SEARCH_LIBS(gethostbyname, resolv bind nsl, ,
415 [AC_MSG_ERROR([cannot find gethostbyname])]) 415 [AC_MSG_ERROR([cannot find gethostbyname])])
416 fi 416 fi
417 LIBOBJS="$LIBOBJS gethostbyname.o" 417 EXTRA_NETOBJS="$EXTRA_NETOBJS gethostbyname.o"
418 AC_DEFINE(EMULATE_GETADDRINFO,1,[Define if emulating getaddrinfo])
418 419
419fi 420fi
420 421
@@ -1451,7 +1452,7 @@ AC_TRY_COMPILE([#ifdef __STDC__
1451 [NEED_VA_LIST=-DNEED_VA_LIST AC_SUBST(NEED_VA_LIST) AC_MSG_RESULT(no)]) 1452 [NEED_VA_LIST=-DNEED_VA_LIST AC_SUBST(NEED_VA_LIST) AC_MSG_RESULT(no)])
1452 1453
1453AC_SUBST(EXTRAS) 1454AC_SUBST(EXTRAS)
1454AC_SUBST(LIBOBJS) 1455AC_SUBST(EXTRA_NETOBJS)
1455AC_SUBST(DEPLIBS) 1456AC_SUBST(DEPLIBS)
1456 1457
1457AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version]) 1458AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version])