summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorKarl DeBisschop <kdebisschop@users.sourceforge.net>2003-03-12 06:38:24 (GMT)
committerKarl DeBisschop <kdebisschop@users.sourceforge.net>2003-03-12 06:38:24 (GMT)
commit8913862c50319cde5b93affefdc504ecbd64fe81 (patch)
tree04d663e823706537d7aad1fc5c3005646e53def0 /configure.in
parentcc525b9e562cc37c215d5350588607dc23bde552 (diff)
downloadmonitoring-plugins-8913862c50319cde5b93affefdc504ecbd64fe81.tar.gz
version increase, statfs work
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@406 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index af524f3..48e4506 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
1dnl Process this file with autoconf to produce a configure script. 1dnl Process this file with autoconf to produce a configure script.
2AC_REVISION ($Revision$) 2AC_REVISION ($Revision$)
3AC_INIT(Helper.pm) 3AC_INIT(Helper.pm)
4VER=1.3.0 4VER=1.3.99
5REL=1 5REL=1
6AC_SUBST(VER) 6AC_SUBST(VER)
7AC_SUBST(REL) 7AC_SUBST(REL)
@@ -478,14 +478,18 @@ AC_HEADER_TIME
478AC_HEADER_SYS_WAIT 478AC_HEADER_SYS_WAIT
479AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h unistd.h uio.h errno.h regex.h sys/types.h sys/time.h sys/socket.h sys/loadavg.h) 479AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h unistd.h uio.h errno.h regex.h sys/types.h sys/time.h sys/socket.h sys/loadavg.h)
480AC_CHECK_HEADERS(stdarg.h sys/unistd.h unistd.h ctype.h stdlib.h) 480AC_CHECK_HEADERS(stdarg.h sys/unistd.h unistd.h ctype.h stdlib.h)
481
482dnl Linux
481AC_CHECK_HEADERS(sys/vfs.h, 483AC_CHECK_HEADERS(sys/vfs.h,
482 [AC_TRY_COMPILE([#include <sys/vfs.h>], 484 [AC_TRY_COMPILE([#include <sys/vfs.h>],
483 [struct statfs *buf], 485 [struct statfs buf; long foo; statfs ("/", &buf); foo = buf.f_namelen;],
484 [AC_DEFINE(HAVE_STRUCT_STATFS,1,[Define if statfs struct can be found])])]) 486 [AC_DEFINE(HAVE_STRUCT_STATFS,1,[Define if statfs struct can be found])])])
487
488dnl FreeBSD
485AC_CHECK_HEADERS(sys/param.h sys/mount.h, 489AC_CHECK_HEADERS(sys/param.h sys/mount.h,
486 [AC_TRY_COMPILE([#include <sys/param.h> 490 [AC_TRY_COMPILE([#include <sys/param.h>
487#include <sys/mount.h>], 491#include <sys/mount.h>],
488 [struct statfs *buf], 492 [struct statfs buf; int foo; statfs ("/", &buf); foo = buf.f_flags;],
489 [AC_DEFINE(HAVE_STRUCT_STATFS,1,[Define if statfs struct can be found])])]) 493 [AC_DEFINE(HAVE_STRUCT_STATFS,1,[Define if statfs struct can be found])])])
490 494
491dnl Checks for typedefs, structures, and compiler characteristics. 495dnl Checks for typedefs, structures, and compiler characteristics.