diff options
author | Diego Elio Pettenò <flameeyes@flameeyes.eu> | 2012-08-18 02:55:11 (GMT) |
---|---|---|
committer | Holger Weiss <holger@zedat.fu-berlin.de> | 2013-05-12 12:15:13 (GMT) |
commit | 10d2261539fa97d7c0e9227bd62cc4e6bef83d45 (patch) | |
tree | b4522ca591d5338f180ca106650c561705a93e78 /configure.in | |
parent | eeca6e0f05ce59361e6084deab6117c240520cdb (diff) | |
download | monitoring-plugins-10d2261539fa97d7c0e9227bd62cc4e6bef83d45.tar.gz |
configure: add --without-ldap, --without-radius and --without-dbi options.
When building for distributions such as Gentoo Linux, or FreeBSD
ports, it's convenient to be able to disable building certain
functionalities even if the dependencies are present, to avoid what
are called "automagic dependendencies".
Adding these parameters solve the issue.
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 91 |
1 files changed, 51 insertions, 40 deletions
diff --git a/configure.in b/configure.in index 1d4ed00..25c0c9c 100644 --- a/configure.in +++ b/configure.in | |||
@@ -255,55 +255,66 @@ fi | |||
255 | LIBS="$_SAVEDLIBS" | 255 | LIBS="$_SAVEDLIBS" |
256 | CPPFLAGS="$_SAVEDCPPFLAGS" | 256 | CPPFLAGS="$_SAVEDCPPFLAGS" |
257 | 257 | ||
258 | AC_ARG_WITH([dbi], [AS_HELP_STRING([--without-dbi], [Skips the dbi plugin])]) | ||
258 | dnl Check for DBI libraries | 259 | dnl Check for DBI libraries |
259 | _SAVEDLIBS="$LIBS" | 260 | AS_IF([test "x$with_dbi" != "xno"], [ |
260 | AC_CHECK_LIB(dbi,dbi_initialize) | 261 | _SAVEDLIBS="$LIBS" |
261 | if test "$ac_cv_lib_dbi_dbi_initialize" = "yes"; then | 262 | AC_CHECK_LIB(dbi,dbi_initialize) |
262 | EXTRAS="$EXTRAS check_dbi" | 263 | if test "$ac_cv_lib_dbi_dbi_initialize" = "yes"; then |
263 | DBILIBS="-ldbi" | 264 | EXTRAS="$EXTRAS check_dbi" |
264 | AC_SUBST(DBILIBS) | 265 | DBILIBS="-ldbi" |
265 | else | 266 | AC_SUBST(DBILIBS) |
266 | AC_MSG_WARN([Skipping dbi plugin]) | 267 | else |
267 | AC_MSG_WARN([install DBI libs to compile this plugin (see REQUIREMENTS).]) | 268 | AC_MSG_WARN([Skipping dbi plugin]) |
268 | fi | 269 | AC_MSG_WARN([install DBI libs to compile this plugin (see REQUIREMENTS).]) |
269 | LIBS="$_SAVEDLIBS" | 270 | fi |
271 | LIBS="$_SAVEDLIBS" | ||
272 | ]) | ||
273 | |||
274 | AC_ARG_WITH([radius], [AS_HELP_STRING([--without-radius], [Skips the radius plugin])]) | ||
270 | 275 | ||
271 | dnl Check for radius libraries | 276 | dnl Check for radius libraries |
272 | _SAVEDLIBS="$LIBS" | 277 | AS_IF([test "x$with_radius" != "xno"], [ |
273 | AC_CHECK_LIB(radiusclient,rc_read_config) | 278 | _SAVEDLIBS="$LIBS" |
274 | if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then | 279 | AC_CHECK_LIB(radiusclient,rc_read_config) |
275 | EXTRAS="$EXTRAS check_radius" | 280 | if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then |
276 | RADIUSLIBS="-lradiusclient" | ||
277 | AC_SUBST(RADIUSLIBS) | ||
278 | else | ||
279 | AC_CHECK_LIB(radiusclient-ng,rc_read_config) | ||
280 | if test "$ac_cv_lib_radiusclient_ng_rc_read_config" = "yes"; then | ||
281 | EXTRAS="$EXTRAS check_radius" | 281 | EXTRAS="$EXTRAS check_radius" |
282 | RADIUSLIBS="-lradiusclient-ng" | 282 | RADIUSLIBS="-lradiusclient" |
283 | AC_SUBST(RADIUSLIBS) | 283 | AC_SUBST(RADIUSLIBS) |
284 | else | 284 | else |
285 | AC_MSG_WARN([Skipping radius plugin]) | 285 | AC_CHECK_LIB(radiusclient-ng,rc_read_config) |
286 | AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).]) | 286 | if test "$ac_cv_lib_radiusclient_ng_rc_read_config" = "yes"; then |
287 | EXTRAS="$EXTRAS check_radius" | ||
288 | RADIUSLIBS="-lradiusclient-ng" | ||
289 | AC_SUBST(RADIUSLIBS) | ||
290 | else | ||
291 | AC_MSG_WARN([Skipping radius plugin]) | ||
292 | AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).]) | ||
293 | fi | ||
287 | fi | 294 | fi |
288 | fi | 295 | LIBS="$_SAVEDLIBS" |
289 | LIBS="$_SAVEDLIBS" | 296 | ]) |
297 | |||
298 | AC_ARG_WITH([ldap], [AS_HELP_STRING([--without-ldap], [Skips the LDAP plugin])]) | ||
290 | 299 | ||
291 | dnl Check for LDAP libraries | 300 | dnl Check for LDAP libraries |
292 | _SAVEDLIBS="$LIBS" | 301 | AS_IF([test "x$with_ldap" != "xno"], [ |
293 | AC_CHECK_LIB(ldap,main,,,-llber) | 302 | _SAVEDLIBS="$LIBS" |
294 | if test "$ac_cv_lib_ldap_main" = "yes"; then | 303 | AC_CHECK_LIB(ldap,main,,,-llber) |
295 | LDAPLIBS="-lldap -llber"\ | 304 | if test "$ac_cv_lib_ldap_main" = "yes"; then |
296 | LDAPINCLUDE="-I/usr/include/ldap" | 305 | LDAPLIBS="-lldap -llber"\ |
297 | AC_SUBST(LDAPLIBS) | 306 | LDAPINCLUDE="-I/usr/include/ldap" |
298 | AC_SUBST(LDAPINCLUDE) | 307 | AC_SUBST(LDAPLIBS) |
299 | AC_CHECK_FUNCS(ldap_set_option) | 308 | AC_SUBST(LDAPINCLUDE) |
300 | EXTRAS="$EXTRAS check_ldap" | 309 | AC_CHECK_FUNCS(ldap_set_option) |
301 | AC_CHECK_FUNCS(ldap_init ldap_set_option ldap_get_option ldap_start_tls_s) | 310 | EXTRAS="$EXTRAS check_ldap" |
302 | else | 311 | AC_CHECK_FUNCS(ldap_init ldap_set_option ldap_get_option ldap_start_tls_s) |
303 | AC_MSG_WARN([Skipping LDAP plugin]) | 312 | else |
304 | AC_MSG_WARN([install LDAP libs to compile this plugin (see REQUIREMENTS).]) | 313 | AC_MSG_WARN([Skipping LDAP plugin]) |
305 | fi | 314 | AC_MSG_WARN([install LDAP libs to compile this plugin (see REQUIREMENTS).]) |
306 | LIBS="$_SAVEDLIBS" | 315 | fi |
316 | LIBS="$_SAVEDLIBS" | ||
317 | ]) | ||
307 | 318 | ||
308 | dnl Check for headers used by check_ide_smart | 319 | dnl Check for headers used by check_ide_smart |
309 | AC_CHECK_HEADER(linux/hdreg.h, FOUNDINCLUDE=yes, FOUNDINCLUDE=no) | 320 | AC_CHECK_HEADER(linux/hdreg.h, FOUNDINCLUDE=yes, FOUNDINCLUDE=no) |