diff options
author | Karl DeBisschop <kdebisschop@users.sourceforge.net> | 2003-03-11 06:44:22 (GMT) |
---|---|---|
committer | Karl DeBisschop <kdebisschop@users.sourceforge.net> | 2003-03-11 06:44:22 (GMT) |
commit | f92835063a238a85cf8ef0cb3ac67f649ab35ebd (patch) | |
tree | 81ba3202e2676385f883d9f2e9f5e0cee4ff523d /configure.in | |
parent | 8a321bef1433cc6a15337900f0d2ce352dae3b6c (diff) | |
download | monitoring-plugins-f92835063a238a85cf8ef0cb3ac67f649ab35ebd.tar.gz |
use statfs for check_disk (still needs fs scan)
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@392 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.in b/configure.in index fcd5c56..8f7f4f9 100644 --- a/configure.in +++ b/configure.in | |||
@@ -21,9 +21,38 @@ AC_PROG_INSTALL | |||
21 | AC_SUBST(INSTALL) | 21 | AC_SUBST(INSTALL) |
22 | 22 | ||
23 | AC_PROG_CC | 23 | AC_PROG_CC |
24 | AC_PROG_CPP | ||
25 | AC_PROG_GCC_TRADITIONAL | ||
26 | AC_PROG_RANLIB | ||
27 | AC_AIX | ||
28 | AC_MINIX | ||
29 | |||
24 | AC_PROG_MAKE_SET | 30 | AC_PROG_MAKE_SET |
25 | AC_PROG_AWK | 31 | AC_PROG_AWK |
26 | 32 | ||
33 | # Check for SunOS statfs brokenness wrt partitions 2GB and larger. | ||
34 | # If <sys/vfs.h> exists and struct statfs has a member named f_spare, | ||
35 | # enable the work-around code in fsusage.c. | ||
36 | AC_MSG_CHECKING([for statfs that truncates block counts]) | ||
37 | AC_CACHE_VAL(fu_cv_sys_truncating_statfs, | ||
38 | [AC_TRY_COMPILE([ | ||
39 | #if !defined(sun) && !defined(__sun) | ||
40 | choke -- this is a workaround for a Sun-specific problem | ||
41 | #endif | ||
42 | #include <sys/types.h> | ||
43 | #include <sys/vfs.h>], | ||
44 | [struct statfs t; long c = *(t.f_spare);], | ||
45 | fu_cv_sys_truncating_statfs=yes, | ||
46 | fu_cv_sys_truncating_statfs=no, | ||
47 | )]) | ||
48 | if test $fu_cv_sys_truncating_statfs = yes; then | ||
49 | AC_DEFINE(STATFS_TRUNCATES_BLOCK_COUNTS, 1, | ||
50 | [ Define if the block counts reported by statfs may be truncated to 2GB | ||
51 | and the correct values may be stored in the f_spare array. | ||
52 | (SunOS 4.1.2, 4.1.3, and 4.1.3_U1 are reported to have this problem. | ||
53 | SunOS 4.1.1 seems not to be affected.)]) | ||
54 | fi | ||
55 | |||
27 | saved_srcdir=$srcdir | 56 | saved_srcdir=$srcdir |
28 | srcdir=$srcdir/lib | 57 | srcdir=$srcdir/lib |
29 | test -f $srcdir/getloadavg.c \ | 58 | test -f $srcdir/getloadavg.c \ |
@@ -447,6 +476,15 @@ AC_HEADER_TIME | |||
447 | AC_HEADER_SYS_WAIT | 476 | AC_HEADER_SYS_WAIT |
448 | AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h unistd.h uio.h errno.h regex.h sys/types.h sys/time.h sys/socket.h sys/loadavg.h) | 477 | AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h unistd.h uio.h errno.h regex.h sys/types.h sys/time.h sys/socket.h sys/loadavg.h) |
449 | AC_CHECK_HEADERS(stdarg.h sys/unistd.h unistd.h ctype.h stdlib.h) | 478 | AC_CHECK_HEADERS(stdarg.h sys/unistd.h unistd.h ctype.h stdlib.h) |
479 | AC_CHECK_HEADERS(sys/vfs.h, | ||
480 | [AC_TRY_COMPILE([#include <sys/vfs.h>], | ||
481 | [struct statfs *buf], | ||
482 | [AC_DEFINE(HAVE_STRUCT_STATFS,1,[Define if statfs struct can be found])])]) | ||
483 | AC_CHECK_HEADERS(sys/param.h sys/mount.h, | ||
484 | [AC_TRY_COMPILE([#include <sys/param.h> | ||
485 | #include <sys/mount.h>], | ||
486 | [struct statfs *buf], | ||
487 | [AC_DEFINE(HAVE_STRUCT_STATFS,1,[Define if statfs struct can be found])])]) | ||
450 | 488 | ||
451 | dnl Checks for typedefs, structures, and compiler characteristics. | 489 | dnl Checks for typedefs, structures, and compiler characteristics. |
452 | AC_C_CONST | 490 | AC_C_CONST |