diff options
author | Thomas Guyot-Sionnest <dermoth@aei.ca> | 2009-03-20 06:48:40 (GMT) |
---|---|---|
committer | Thomas Guyot-Sionnest <dermoth@aei.ca> | 2009-03-20 06:57:11 (GMT) |
commit | 3fa3707b5752adfe348e101a194635cc11ace2af (patch) | |
tree | b8a8d4e0c1db4a056ea64224ba7d06dcf630a48b /gl/Makefile.am | |
parent | d36c97612990ac81d2dc0452b980e8708477df76 (diff) | |
download | monitoring-plugins-3fa3707b5752adfe348e101a194635cc11ace2af.tar.gz |
Add the timegm Gnulib module
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r-- | gl/Makefile.am | 56 |
1 files changed, 55 insertions, 1 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am index 1a407c5..cae814f 100644 --- a/gl/Makefile.am +++ b/gl/Makefile.am | |||
@@ -9,7 +9,7 @@ | |||
9 | # the same distribution terms as the rest of that program. | 9 | # the same distribution terms as the rest of that program. |
10 | # | 10 | # |
11 | # Generated by gnulib-tool. | 11 | # Generated by gnulib-tool. |
12 | # Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl base64 dirname floorf fsusage getaddrinfo gethostname getloadavg getopt gettext mountlist regex vasprintf vsnprintf | 12 | # Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl base64 dirname floorf fsusage getaddrinfo gethostname getloadavg getopt gettext mountlist regex timegm vasprintf vsnprintf |
13 | 13 | ||
14 | AUTOMAKE_OPTIONS = 1.5 gnits | 14 | AUTOMAKE_OPTIONS = 1.5 gnits |
15 | 15 | ||
@@ -589,6 +589,15 @@ EXTRA_libgnu_a_SOURCES += mbsinit.c | |||
589 | 589 | ||
590 | ## end gnulib module mbsinit | 590 | ## end gnulib module mbsinit |
591 | 591 | ||
592 | ## begin gnulib module mktime | ||
593 | |||
594 | |||
595 | EXTRA_DIST += mktime.c | ||
596 | |||
597 | EXTRA_libgnu_a_SOURCES += mktime.c | ||
598 | |||
599 | ## end gnulib module mktime | ||
600 | |||
592 | ## begin gnulib module mountlist | 601 | ## begin gnulib module mountlist |
593 | 602 | ||
594 | 603 | ||
@@ -1056,6 +1065,51 @@ EXTRA_DIST += sys_socket.in.h | |||
1056 | 1065 | ||
1057 | ## end gnulib module sys_socket | 1066 | ## end gnulib module sys_socket |
1058 | 1067 | ||
1068 | ## begin gnulib module time | ||
1069 | |||
1070 | BUILT_SOURCES += time.h | ||
1071 | |||
1072 | # We need the following in order to create <time.h> when the system | ||
1073 | # doesn't have one that works with the given compiler. | ||
1074 | time.h: time.in.h | ||
1075 | rm -f $@-t $@ | ||
1076 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */' && \ | ||
1077 | sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \ | ||
1078 | -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \ | ||
1079 | -e 's|@NEXT_TIME_H''@|$(NEXT_TIME_H)|g' \ | ||
1080 | -e 's|@REPLACE_LOCALTIME_R''@|$(REPLACE_LOCALTIME_R)|g' \ | ||
1081 | -e 's|@REPLACE_NANOSLEEP''@|$(REPLACE_NANOSLEEP)|g' \ | ||
1082 | -e 's|@REPLACE_STRPTIME''@|$(REPLACE_STRPTIME)|g' \ | ||
1083 | -e 's|@REPLACE_TIMEGM''@|$(REPLACE_TIMEGM)|g' \ | ||
1084 | -e 's|@SYS_TIME_H_DEFINES_STRUCT_TIMESPEC''@|$(SYS_TIME_H_DEFINES_STRUCT_TIMESPEC)|g' \ | ||
1085 | -e 's|@TIME_H_DEFINES_STRUCT_TIMESPEC''@|$(TIME_H_DEFINES_STRUCT_TIMESPEC)|g' \ | ||
1086 | < $(srcdir)/time.in.h; \ | ||
1087 | } > $@-t | ||
1088 | mv $@-t $@ | ||
1089 | MOSTLYCLEANFILES += time.h time.h-t | ||
1090 | |||
1091 | EXTRA_DIST += time.in.h | ||
1092 | |||
1093 | ## end gnulib module time | ||
1094 | |||
1095 | ## begin gnulib module time_r | ||
1096 | |||
1097 | |||
1098 | EXTRA_DIST += time_r.c | ||
1099 | |||
1100 | EXTRA_libgnu_a_SOURCES += time_r.c | ||
1101 | |||
1102 | ## end gnulib module time_r | ||
1103 | |||
1104 | ## begin gnulib module timegm | ||
1105 | |||
1106 | |||
1107 | EXTRA_DIST += timegm.c | ||
1108 | |||
1109 | EXTRA_libgnu_a_SOURCES += timegm.c | ||
1110 | |||
1111 | ## end gnulib module timegm | ||
1112 | |||
1059 | ## begin gnulib module unistd | 1113 | ## begin gnulib module unistd |
1060 | 1114 | ||
1061 | BUILT_SOURCES += unistd.h | 1115 | BUILT_SOURCES += unistd.h |