diff options
author | Ton Voon <ton.voon@opsera.com> | 2010-06-17 09:16:43 (GMT) |
---|---|---|
committer | tonvoon <ton.voon@opsera.com> | 2010-06-23 13:30:34 (GMT) |
commit | 18f6835edaf7d640a2c9e476cb1babdbdadbfd9b (patch) | |
tree | ae11f40e48dc34658445c99012726f32bfb45c56 /gl/Makefile.am | |
parent | f61412478ceb7c821793c8356b936f64066508bf (diff) | |
download | monitoring-plugins-18f6835edaf7d640a2c9e476cb1babdbdadbfd9b.tar.gz |
Added state retention APIs. Implemented for check_snmp with --rate option.
See http://nagiosplugin.org/c-api-private for more details on the API.
Also updated check_snmp -l option to change the perfdata label.
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r-- | gl/Makefile.am | 34 |
1 files changed, 20 insertions, 14 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am index e2dc38b..7954b03 100644 --- a/gl/Makefile.am +++ b/gl/Makefile.am | |||
@@ -9,7 +9,7 @@ | |||
9 | # the same distribution terms as the rest of that program. | 9 | # the same distribution terms as the rest of that program. |
10 | # | 10 | # |
11 | # Generated by gnulib-tool. | 11 | # Generated by gnulib-tool. |
12 | # Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl base64 dirname floorf fsusage getaddrinfo gethostname getloadavg getopt gettext mountlist regex timegm vasprintf vsnprintf | 12 | # Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl --no-vc-files base64 crypto/sha1 dirname floorf fsusage getaddrinfo gethostname getloadavg getopt gettext mountlist regex timegm vasprintf vsnprintf |
13 | 13 | ||
14 | AUTOMAKE_OPTIONS = 1.5 gnits | 14 | AUTOMAKE_OPTIONS = 1.5 gnits |
15 | 15 | ||
@@ -44,17 +44,6 @@ EXTRA_DIST += alignof.h | |||
44 | 44 | ||
45 | ## end gnulib module alignof | 45 | ## end gnulib module alignof |
46 | 46 | ||
47 | ## begin gnulib module alloca | ||
48 | |||
49 | |||
50 | EXTRA_DIST += alloca.c | ||
51 | |||
52 | EXTRA_libgnu_a_SOURCES += alloca.c | ||
53 | |||
54 | libgnu_a_LIBADD += @ALLOCA@ | ||
55 | libgnu_a_DEPENDENCIES += @ALLOCA@ | ||
56 | ## end gnulib module alloca | ||
57 | |||
58 | ## begin gnulib module alloca-opt | 47 | ## begin gnulib module alloca-opt |
59 | 48 | ||
60 | BUILT_SOURCES += $(ALLOCA_H) | 49 | BUILT_SOURCES += $(ALLOCA_H) |
@@ -253,6 +242,15 @@ CLEANFILES += configmake.h configmake.h-t | |||
253 | 242 | ||
254 | ## end gnulib module configmake | 243 | ## end gnulib module configmake |
255 | 244 | ||
245 | ## begin gnulib module crypto/sha1 | ||
246 | |||
247 | |||
248 | EXTRA_DIST += sha1.c sha1.h | ||
249 | |||
250 | EXTRA_libgnu_a_SOURCES += sha1.c | ||
251 | |||
252 | ## end gnulib module crypto/sha1 | ||
253 | |||
256 | ## begin gnulib module dirname | 254 | ## begin gnulib module dirname |
257 | 255 | ||
258 | 256 | ||
@@ -833,11 +831,11 @@ EXTRA_libgnu_a_SOURCES += mountlist.c | |||
833 | 831 | ||
834 | ## begin gnulib module netdb | 832 | ## begin gnulib module netdb |
835 | 833 | ||
836 | BUILT_SOURCES += $(NETDB_H) | 834 | BUILT_SOURCES += netdb.h |
837 | 835 | ||
838 | # We need the following in order to create <netdb.h> when the system | 836 | # We need the following in order to create <netdb.h> when the system |
839 | # doesn't have one that works with the given compiler. | 837 | # doesn't have one that works with the given compiler. |
840 | netdb.h: netdb.in.h $(ARG_NONNULL_H) | 838 | netdb.h: netdb.in.h $(ARG_NONNULL_H) $(WARN_ON_USE_H) |
841 | $(AM_V_GEN)rm -f $@-t $@ && \ | 839 | $(AM_V_GEN)rm -f $@-t $@ && \ |
842 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | 840 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ |
843 | sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \ | 841 | sed -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \ |
@@ -851,6 +849,7 @@ netdb.h: netdb.in.h $(ARG_NONNULL_H) | |||
851 | -e 's|@''HAVE_DECL_GETADDRINFO''@|$(HAVE_DECL_GETADDRINFO)|g' \ | 849 | -e 's|@''HAVE_DECL_GETADDRINFO''@|$(HAVE_DECL_GETADDRINFO)|g' \ |
852 | -e 's|@''HAVE_DECL_GETNAMEINFO''@|$(HAVE_DECL_GETNAMEINFO)|g' \ | 850 | -e 's|@''HAVE_DECL_GETNAMEINFO''@|$(HAVE_DECL_GETNAMEINFO)|g' \ |
853 | -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \ | 851 | -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \ |
852 | -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)' \ | ||
854 | < $(srcdir)/netdb.in.h; \ | 853 | < $(srcdir)/netdb.in.h; \ |
855 | } > $@-t && \ | 854 | } > $@-t && \ |
856 | mv $@-t $@ | 855 | mv $@-t $@ |
@@ -1140,6 +1139,7 @@ stdio.h: stdio.in.h $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H) | |||
1140 | -e 's|@''REPLACE_VPRINTF''@|$(REPLACE_VPRINTF)|g' \ | 1139 | -e 's|@''REPLACE_VPRINTF''@|$(REPLACE_VPRINTF)|g' \ |
1141 | -e 's|@''REPLACE_VSNPRINTF''@|$(REPLACE_VSNPRINTF)|g' \ | 1140 | -e 's|@''REPLACE_VSNPRINTF''@|$(REPLACE_VSNPRINTF)|g' \ |
1142 | -e 's|@''REPLACE_VSPRINTF''@|$(REPLACE_VSPRINTF)|g' \ | 1141 | -e 's|@''REPLACE_VSPRINTF''@|$(REPLACE_VSPRINTF)|g' \ |
1142 | -e 's|@''ASM_SYMBOL_PREFIX''@|$(ASM_SYMBOL_PREFIX)|g' \ | ||
1143 | -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \ | 1143 | -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \ |
1144 | -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \ | 1144 | -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \ |
1145 | -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)'; \ | 1145 | -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)'; \ |
@@ -1333,6 +1333,7 @@ string.h: string.in.h $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H) | |||
1333 | -e 's|@''REPLACE_STRERROR''@|$(REPLACE_STRERROR)|g' \ | 1333 | -e 's|@''REPLACE_STRERROR''@|$(REPLACE_STRERROR)|g' \ |
1334 | -e 's|@''REPLACE_STRNCAT''@|$(REPLACE_STRNCAT)|g' \ | 1334 | -e 's|@''REPLACE_STRNCAT''@|$(REPLACE_STRNCAT)|g' \ |
1335 | -e 's|@''REPLACE_STRNDUP''@|$(REPLACE_STRNDUP)|g' \ | 1335 | -e 's|@''REPLACE_STRNDUP''@|$(REPLACE_STRNDUP)|g' \ |
1336 | -e 's|@''REPLACE_STRNLEN''@|$(REPLACE_STRNLEN)|g' \ | ||
1336 | -e 's|@''REPLACE_STRSIGNAL''@|$(REPLACE_STRSIGNAL)|g' \ | 1337 | -e 's|@''REPLACE_STRSIGNAL''@|$(REPLACE_STRSIGNAL)|g' \ |
1337 | -e 's|@''REPLACE_STRTOK_R''@|$(REPLACE_STRTOK_R)|g' \ | 1338 | -e 's|@''REPLACE_STRTOK_R''@|$(REPLACE_STRTOK_R)|g' \ |
1338 | -e 's|@''UNDEFINE_STRTOK_R''@|$(UNDEFINE_STRTOK_R)|g' \ | 1339 | -e 's|@''UNDEFINE_STRTOK_R''@|$(UNDEFINE_STRTOK_R)|g' \ |
@@ -1506,6 +1507,7 @@ time.h: time.in.h $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H) | |||
1506 | -e 's|@''REPLACE_MKTIME''@|$(REPLACE_MKTIME)|g' \ | 1507 | -e 's|@''REPLACE_MKTIME''@|$(REPLACE_MKTIME)|g' \ |
1507 | -e 's|@''REPLACE_NANOSLEEP''@|$(REPLACE_NANOSLEEP)|g' \ | 1508 | -e 's|@''REPLACE_NANOSLEEP''@|$(REPLACE_NANOSLEEP)|g' \ |
1508 | -e 's|@''REPLACE_TIMEGM''@|$(REPLACE_TIMEGM)|g' \ | 1509 | -e 's|@''REPLACE_TIMEGM''@|$(REPLACE_TIMEGM)|g' \ |
1510 | -e 's|@''PTHREAD_H_DEFINES_STRUCT_TIMESPEC''@|$(PTHREAD_H_DEFINES_STRUCT_TIMESPEC)|g' \ | ||
1509 | -e 's|@''SYS_TIME_H_DEFINES_STRUCT_TIMESPEC''@|$(SYS_TIME_H_DEFINES_STRUCT_TIMESPEC)|g' \ | 1511 | -e 's|@''SYS_TIME_H_DEFINES_STRUCT_TIMESPEC''@|$(SYS_TIME_H_DEFINES_STRUCT_TIMESPEC)|g' \ |
1510 | -e 's|@''TIME_H_DEFINES_STRUCT_TIMESPEC''@|$(TIME_H_DEFINES_STRUCT_TIMESPEC)|g' \ | 1512 | -e 's|@''TIME_H_DEFINES_STRUCT_TIMESPEC''@|$(TIME_H_DEFINES_STRUCT_TIMESPEC)|g' \ |
1511 | -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \ | 1513 | -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \ |
@@ -1577,6 +1579,7 @@ unistd.h: unistd.in.h $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H) | |||
1577 | -e 's|@''GNULIB_LSEEK''@|$(GNULIB_LSEEK)|g' \ | 1579 | -e 's|@''GNULIB_LSEEK''@|$(GNULIB_LSEEK)|g' \ |
1578 | -e 's|@''GNULIB_PIPE2''@|$(GNULIB_PIPE2)|g' \ | 1580 | -e 's|@''GNULIB_PIPE2''@|$(GNULIB_PIPE2)|g' \ |
1579 | -e 's|@''GNULIB_PREAD''@|$(GNULIB_PREAD)|g' \ | 1581 | -e 's|@''GNULIB_PREAD''@|$(GNULIB_PREAD)|g' \ |
1582 | -e 's|@''GNULIB_PWRITE''@|$(GNULIB_PWRITE)|g' \ | ||
1580 | -e 's|@''GNULIB_READLINK''@|$(GNULIB_READLINK)|g' \ | 1583 | -e 's|@''GNULIB_READLINK''@|$(GNULIB_READLINK)|g' \ |
1581 | -e 's|@''GNULIB_READLINKAT''@|$(GNULIB_READLINKAT)|g' \ | 1584 | -e 's|@''GNULIB_READLINKAT''@|$(GNULIB_READLINKAT)|g' \ |
1582 | -e 's|@''GNULIB_RMDIR''@|$(GNULIB_RMDIR)|g' \ | 1585 | -e 's|@''GNULIB_RMDIR''@|$(GNULIB_RMDIR)|g' \ |
@@ -1611,6 +1614,7 @@ unistd.h: unistd.in.h $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H) | |||
1611 | -e 's|@''HAVE_LINKAT''@|$(HAVE_LINKAT)|g' \ | 1614 | -e 's|@''HAVE_LINKAT''@|$(HAVE_LINKAT)|g' \ |
1612 | -e 's|@''HAVE_PIPE2''@|$(HAVE_PIPE2)|g' \ | 1615 | -e 's|@''HAVE_PIPE2''@|$(HAVE_PIPE2)|g' \ |
1613 | -e 's|@''HAVE_PREAD''@|$(HAVE_PREAD)|g' \ | 1616 | -e 's|@''HAVE_PREAD''@|$(HAVE_PREAD)|g' \ |
1617 | -e 's|@''HAVE_PWRITE''@|$(HAVE_PWRITE)|g' \ | ||
1614 | -e 's|@''HAVE_READLINK''@|$(HAVE_READLINK)|g' \ | 1618 | -e 's|@''HAVE_READLINK''@|$(HAVE_READLINK)|g' \ |
1615 | -e 's|@''HAVE_READLINKAT''@|$(HAVE_READLINKAT)|g' \ | 1619 | -e 's|@''HAVE_READLINKAT''@|$(HAVE_READLINKAT)|g' \ |
1616 | -e 's|@''HAVE_SLEEP''@|$(HAVE_SLEEP)|g' \ | 1620 | -e 's|@''HAVE_SLEEP''@|$(HAVE_SLEEP)|g' \ |
@@ -1638,10 +1642,12 @@ unistd.h: unistd.in.h $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H) | |||
1638 | -e 's|@''REPLACE_LINKAT''@|$(REPLACE_LINKAT)|g' \ | 1642 | -e 's|@''REPLACE_LINKAT''@|$(REPLACE_LINKAT)|g' \ |
1639 | -e 's|@''REPLACE_LSEEK''@|$(REPLACE_LSEEK)|g' \ | 1643 | -e 's|@''REPLACE_LSEEK''@|$(REPLACE_LSEEK)|g' \ |
1640 | -e 's|@''REPLACE_PREAD''@|$(REPLACE_PREAD)|g' \ | 1644 | -e 's|@''REPLACE_PREAD''@|$(REPLACE_PREAD)|g' \ |
1645 | -e 's|@''REPLACE_PWRITE''@|$(REPLACE_PWRITE)|g' \ | ||
1641 | -e 's|@''REPLACE_READLINK''@|$(REPLACE_READLINK)|g' \ | 1646 | -e 's|@''REPLACE_READLINK''@|$(REPLACE_READLINK)|g' \ |
1642 | -e 's|@''REPLACE_RMDIR''@|$(REPLACE_RMDIR)|g' \ | 1647 | -e 's|@''REPLACE_RMDIR''@|$(REPLACE_RMDIR)|g' \ |
1643 | -e 's|@''REPLACE_SLEEP''@|$(REPLACE_SLEEP)|g' \ | 1648 | -e 's|@''REPLACE_SLEEP''@|$(REPLACE_SLEEP)|g' \ |
1644 | -e 's|@''REPLACE_SYMLINK''@|$(REPLACE_SYMLINK)|g' \ | 1649 | -e 's|@''REPLACE_SYMLINK''@|$(REPLACE_SYMLINK)|g' \ |
1650 | -e 's|@''REPLACE_TTYNAME_R''@|$(REPLACE_TTYNAME_R)|g' \ | ||
1645 | -e 's|@''REPLACE_UNLINK''@|$(REPLACE_UNLINK)|g' \ | 1651 | -e 's|@''REPLACE_UNLINK''@|$(REPLACE_UNLINK)|g' \ |
1646 | -e 's|@''REPLACE_UNLINKAT''@|$(REPLACE_UNLINKAT)|g' \ | 1652 | -e 's|@''REPLACE_UNLINKAT''@|$(REPLACE_UNLINKAT)|g' \ |
1647 | -e 's|@''REPLACE_USLEEP''@|$(REPLACE_USLEEP)|g' \ | 1653 | -e 's|@''REPLACE_USLEEP''@|$(REPLACE_USLEEP)|g' \ |