diff options
author | Thomas Guyot-Sionnest <dermoth@users.sourceforge.net> | 2008-02-12 12:03:58 (GMT) |
---|---|---|
committer | Thomas Guyot-Sionnest <dermoth@users.sourceforge.net> | 2008-02-12 12:03:58 (GMT) |
commit | abbad00edd7f5f3d33ae77a9d5ac338e5bea5fb3 (patch) | |
tree | 0d55fb4d8e5ad7a9376d1bccdea31104cbecacfe /gl/Makefile.am | |
parent | bd7029a99b0c2974265c6665638ef14a052f42ab (diff) | |
download | monitoring-plugins-abbad00edd7f5f3d33ae77a9d5ac338e5bea5fb3.tar.gz |
Import Gnulib floorf and base64 and removed our old base64 library.
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1926 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r-- | gl/Makefile.am | 81 |
1 files changed, 80 insertions, 1 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am index 92c675e..1eefee9 100644 --- a/gl/Makefile.am +++ b/gl/Makefile.am | |||
@@ -9,7 +9,7 @@ | |||
9 | # the same distribution terms as the rest of that program. | 9 | # the same distribution terms as the rest of that program. |
10 | # | 10 | # |
11 | # Generated by gnulib-tool. | 11 | # Generated by gnulib-tool. |
12 | # Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --aux-dir=build-aux --no-libtool --macro-prefix=gl dirname fsusage getaddrinfo gethostname getloadavg getopt gettext mountlist regex vasprintf vsnprintf | 12 | # Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --aux-dir=build-aux --no-libtool --macro-prefix=gl base64 dirname floorf fsusage getaddrinfo gethostname getloadavg getopt gettext mountlist regex vasprintf vsnprintf |
13 | 13 | ||
14 | AUTOMAKE_OPTIONS = 1.5 gnits | 14 | AUTOMAKE_OPTIONS = 1.5 gnits |
15 | 15 | ||
@@ -89,6 +89,12 @@ MOSTLYCLEANDIRS += arpa | |||
89 | 89 | ||
90 | ## end gnulib module arpa_inet | 90 | ## end gnulib module arpa_inet |
91 | 91 | ||
92 | ## begin gnulib module base64 | ||
93 | |||
94 | libgnu_a_SOURCES += base64.h base64.c | ||
95 | |||
96 | ## end gnulib module base64 | ||
97 | |||
92 | ## begin gnulib module c-strtod | 98 | ## begin gnulib module c-strtod |
93 | 99 | ||
94 | 100 | ||
@@ -219,6 +225,15 @@ EXTRA_DIST += float.in.h | |||
219 | 225 | ||
220 | ## end gnulib module float | 226 | ## end gnulib module float |
221 | 227 | ||
228 | ## begin gnulib module floorf | ||
229 | |||
230 | |||
231 | EXTRA_DIST += floor.c floorf.c | ||
232 | |||
233 | EXTRA_libgnu_a_SOURCES += floor.c floorf.c | ||
234 | |||
235 | ## end gnulib module floorf | ||
236 | |||
222 | ## begin gnulib module fsusage | 237 | ## begin gnulib module fsusage |
223 | 238 | ||
224 | 239 | ||
@@ -415,6 +430,70 @@ EXTRA_libgnu_a_SOURCES += malloc.c | |||
415 | 430 | ||
416 | ## end gnulib module malloc-posix | 431 | ## end gnulib module malloc-posix |
417 | 432 | ||
433 | ## begin gnulib module math | ||
434 | |||
435 | BUILT_SOURCES += math.h | ||
436 | |||
437 | # We need the following in order to create <math.h> when the system | ||
438 | # doesn't have one that works with the given compiler. | ||
439 | math.h: math.in.h | ||
440 | rm -f $@-t $@ | ||
441 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */' && \ | ||
442 | sed -e 's/@''INCLUDE_NEXT''@/$(INCLUDE_NEXT)/g' \ | ||
443 | -e 's|@''NEXT_MATH_H''@|$(NEXT_MATH_H)|g' \ | ||
444 | -e 's|@''GNULIB_CEILF''@|$(GNULIB_CEILF)|g' \ | ||
445 | -e 's|@''GNULIB_CEILL''@|$(GNULIB_CEILL)|g' \ | ||
446 | -e 's|@''GNULIB_FLOORF''@|$(GNULIB_FLOORF)|g' \ | ||
447 | -e 's|@''GNULIB_FLOORL''@|$(GNULIB_FLOORL)|g' \ | ||
448 | -e 's|@''GNULIB_FREXP''@|$(GNULIB_FREXP)|g' \ | ||
449 | -e 's|@''GNULIB_FREXPL''@|$(GNULIB_FREXPL)|g' \ | ||
450 | -e 's|@''GNULIB_ISFINITE''@|$(GNULIB_ISFINITE)|g' \ | ||
451 | -e 's|@''GNULIB_LDEXPL''@|$(GNULIB_LDEXPL)|g' \ | ||
452 | -e 's|@''GNULIB_MATHL''@|$(GNULIB_MATHL)|g' \ | ||
453 | -e 's|@''GNULIB_ROUND''@|$(GNULIB_ROUND)|g' \ | ||
454 | -e 's|@''GNULIB_ROUNDF''@|$(GNULIB_ROUNDF)|g' \ | ||
455 | -e 's|@''GNULIB_ROUNDL''@|$(GNULIB_ROUNDL)|g' \ | ||
456 | -e 's|@''GNULIB_SIGNBIT''@|$(GNULIB_SIGNBIT)|g' \ | ||
457 | -e 's|@''GNULIB_TRUNC''@|$(GNULIB_TRUNC)|g' \ | ||
458 | -e 's|@''GNULIB_TRUNCF''@|$(GNULIB_TRUNCF)|g' \ | ||
459 | -e 's|@''GNULIB_TRUNCL''@|$(GNULIB_TRUNCL)|g' \ | ||
460 | -e 's|@''HAVE_DECL_ACOSL''@|$(HAVE_DECL_ACOSL)|g' \ | ||
461 | -e 's|@''HAVE_DECL_ASINL''@|$(HAVE_DECL_ASINL)|g' \ | ||
462 | -e 's|@''HAVE_DECL_ATANL''@|$(HAVE_DECL_ATANL)|g' \ | ||
463 | -e 's|@''HAVE_DECL_COSL''@|$(HAVE_DECL_COSL)|g' \ | ||
464 | -e 's|@''HAVE_DECL_EXPL''@|$(HAVE_DECL_EXPL)|g' \ | ||
465 | -e 's|@''HAVE_DECL_FREXPL''@|$(HAVE_DECL_FREXPL)|g' \ | ||
466 | -e 's|@''HAVE_DECL_LDEXPL''@|$(HAVE_DECL_LDEXPL)|g' \ | ||
467 | -e 's|@''HAVE_DECL_LOGL''@|$(HAVE_DECL_LOGL)|g' \ | ||
468 | -e 's|@''HAVE_DECL_SINL''@|$(HAVE_DECL_SINL)|g' \ | ||
469 | -e 's|@''HAVE_DECL_SQRTL''@|$(HAVE_DECL_SQRTL)|g' \ | ||
470 | -e 's|@''HAVE_DECL_TANL''@|$(HAVE_DECL_TANL)|g' \ | ||
471 | -e 's|@''HAVE_DECL_TRUNC''@|$(HAVE_DECL_TRUNC)|g' \ | ||
472 | -e 's|@''HAVE_DECL_TRUNCF''@|$(HAVE_DECL_TRUNCF)|g' \ | ||
473 | -e 's|@''HAVE_DECL_TRUNCL''@|$(HAVE_DECL_TRUNCL)|g' \ | ||
474 | -e 's|@''REPLACE_CEILF''@|$(REPLACE_CEILF)|g' \ | ||
475 | -e 's|@''REPLACE_CEILL''@|$(REPLACE_CEILL)|g' \ | ||
476 | -e 's|@''REPLACE_FLOORF''@|$(REPLACE_FLOORF)|g' \ | ||
477 | -e 's|@''REPLACE_FLOORL''@|$(REPLACE_FLOORL)|g' \ | ||
478 | -e 's|@''REPLACE_FREXP''@|$(REPLACE_FREXP)|g' \ | ||
479 | -e 's|@''REPLACE_FREXPL''@|$(REPLACE_FREXPL)|g' \ | ||
480 | -e 's|@''REPLACE_ISFINITE''@|$(REPLACE_ISFINITE)|g' \ | ||
481 | -e 's|@''REPLACE_LDEXPL''@|$(REPLACE_LDEXPL)|g' \ | ||
482 | -e 's|@''REPLACE_ROUND''@|$(REPLACE_ROUND)|g' \ | ||
483 | -e 's|@''REPLACE_ROUNDF''@|$(REPLACE_ROUNDF)|g' \ | ||
484 | -e 's|@''REPLACE_ROUNDL''@|$(REPLACE_ROUNDL)|g' \ | ||
485 | -e 's|@''REPLACE_SIGNBIT''@|$(REPLACE_SIGNBIT)|g' \ | ||
486 | -e 's|@''REPLACE_SIGNBIT_USING_GCC''@|$(REPLACE_SIGNBIT_USING_GCC)|g' \ | ||
487 | -e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \ | ||
488 | < $(srcdir)/math.in.h; \ | ||
489 | } > $@-t | ||
490 | mv $@-t $@ | ||
491 | MOSTLYCLEANFILES += math.h math.h-t | ||
492 | |||
493 | EXTRA_DIST += math.in.h | ||
494 | |||
495 | ## end gnulib module math | ||
496 | |||
418 | ## begin gnulib module mountlist | 497 | ## begin gnulib module mountlist |
419 | 498 | ||
420 | 499 | ||