diff options
author | Ethan Galstad <egalstad@users.sourceforge.net> | 2002-02-28 06:42:51 (GMT) |
---|---|---|
committer | Ethan Galstad <egalstad@users.sourceforge.net> | 2002-02-28 06:42:51 (GMT) |
commit | 44a321cb8a42d6c0ea2d96a1086a17f2134c89cc (patch) | |
tree | a1a4d9f7b92412a17ab08f34f04eec45433048b7 /plugins-scripts/Makefile.am | |
parent | 54fd5d7022ff2d6a59bc52b8869182f3fc77a058 (diff) | |
download | monitoring-plugins-44a321cb8a42d6c0ea2d96a1086a17f2134c89cc.tar.gz |
Initial revision
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@2 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r-- | plugins-scripts/Makefile.am | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am new file mode 100644 index 0000000..4bdf717 --- /dev/null +++ b/plugins-scripts/Makefile.am | |||
@@ -0,0 +1,30 @@ | |||
1 | ## Process this file with automake to produce Makefile.in | ||
2 | |||
3 | SUFFIXES = .pl .sh | ||
4 | |||
5 | VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t | ||
6 | |||
7 | libexec_SCRIPTS = check_breeze check_disk_smb check_flexlm check_ircd \ | ||
8 | check_log check_ntp check_oracle check_rpc check_sensors check_wave \ | ||
9 | utils.sh utils.pm | ||
10 | |||
11 | EXTRA_DIST=check_breeze.pl check_disk_smb.pl check_flexlm.pl check_ircd.pl \ | ||
12 | check_log.sh check_ntp.pl check_oracle.sh check_rpc.pl check_sensors.sh \ | ||
13 | check_wave.pl utils.sh.in utils.pm.in t | ||
14 | |||
15 | TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir) | ||
16 | |||
17 | TESTS = @SCRIPT_TEST@ | ||
18 | |||
19 | test: | ||
20 | perl -I $(top_builddir) -I $(top_srcdir) ../test.pl | ||
21 | |||
22 | CLEANFILES=$(libexec_SCRIPTS) | ||
23 | |||
24 | .pl : | ||
25 | $(AWK) -f ./subst $< > $@ | ||
26 | chmod +x $@ | ||
27 | |||
28 | .sh : | ||
29 | $(AWK) -f ./subst $< > $@ | ||
30 | chmod +x $@ | ||