diff options
author | Holger Weiss <holger@zedat.fu-berlin.de> | 2014-02-28 12:28:33 (GMT) |
---|---|---|
committer | Holger Weiss <holger@zedat.fu-berlin.de> | 2014-02-28 12:28:33 (GMT) |
commit | c08d6a429ba0e0cd3642ba2c2fe85687472ee22f (patch) | |
tree | 396a37ae462543f0e28f36501c30796b3eb91249 /plugins-scripts/Makefile.am | |
parent | e260efb25690b13002a0bf432507f66bdad90f02 (diff) | |
download | monitoring-plugins-c08d6a429ba0e0cd3642ba2c2fe85687472ee22f.tar.gz |
Replace "plugins-scripts/subst.in" foo
Remove the buggy and complex awk(1) magic in "plugins-scripts/subst.in"
in favor of simple sed(1) substitutions.
The plugins in the "plugins-scripts" directory now always use the PATH
specified via "./configure --trusted-path", or the default PATH
hard-coded in "configure.ac".
Fixes #1242.
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r-- | plugins-scripts/Makefile.am | 9 |
1 files changed, 7 insertions, 2 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am index 4ea262a..78a950c 100644 --- a/plugins-scripts/Makefile.am +++ b/plugins-scripts/Makefile.am | |||
@@ -23,6 +23,11 @@ EXTRA_DIST=check_breeze.pl check_disk_smb.pl check_flexlm.pl check_ircd.pl \ | |||
23 | check_ifstatus.pl check_ifoperstatus.pl check_wave.pl check_mailq.pl check_file_age.pl \ | 23 | check_ifstatus.pl check_ifoperstatus.pl check_wave.pl check_mailq.pl check_file_age.pl \ |
24 | utils.sh.in utils.pm.in t | 24 | utils.sh.in utils.pm.in t |
25 | 25 | ||
26 | EDIT = sed \ | ||
27 | -e 's|[@]NP_VERSION[@]|$(NP_VERSION)|g' \ | ||
28 | -e 's|[@]TRUSTED_PATH[@]|$(with_trusted_path)|g' \ | ||
29 | -e 's|[@]PERL[@]|$(PERL)|g' | ||
30 | |||
26 | TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir) | 31 | TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir) |
27 | 32 | ||
28 | TESTS = @SCRIPT_TEST@ | 33 | TESTS = @SCRIPT_TEST@ |
@@ -38,11 +43,11 @@ test-debug: | |||
38 | CLEANFILES=$(libexec_SCRIPTS) | 43 | CLEANFILES=$(libexec_SCRIPTS) |
39 | 44 | ||
40 | .pl : | 45 | .pl : |
41 | NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@ | 46 | $(EDIT) $< > $@ |
42 | chmod +x $@ | 47 | chmod +x $@ |
43 | 48 | ||
44 | .sh : | 49 | .sh : |
45 | NP_VERSION=$(NP_VERSION) $(AWK) -f ./subst $< > $@ | 50 | $(EDIT) $< > $@ |
46 | chmod +x $@ | 51 | chmod +x $@ |
47 | 52 | ||
48 | clean-local: | 53 | clean-local: |