diff options
author | M. Sean Finney <seanius@users.sourceforge.net> | 2006-05-01 21:52:42 (GMT) |
---|---|---|
committer | M. Sean Finney <seanius@users.sourceforge.net> | 2006-05-01 21:52:42 (GMT) |
commit | e667553b97c358f5d80608f62c291deffc0328d5 (patch) | |
tree | 4e74625613f8d13f51752d84f03b436b45164ff7 /plugins/Makefile.am | |
parent | 3b91dfbcb05dbfa9a1a20c6ba233c5d163e06821 (diff) | |
download | monitoring-plugins-e667553b97c358f5d80608f62c291deffc0328d5.tar.gz |
- check_ntp:
- now roughly feature-complete.
- various bugfixes, esp. offset calculation.
- enhanced the asynchronous offset polling to set requests that
haven't recieved a response in >= 1 second to stale and retransmit them,
which results in much better performance on unreliable networks.
- we only spend timeout/2 seconds polling offsets, and if we don't get
everything by that point we work with what we have and set status to
warning/critical depending on how much data we have.
- set the same defaults as the perl script.
- commit changes to configure.in to support automatic building of check_apt
(if apt-get is installed and regex libraries available) and check_ntp
(unconditionally), now defaulting to check_ntp.c instead of the perl script.
if this is an issue we can back out the commit of course. an eye
should be kept on check_ntp building and running correctly in different
environments, esp. 64-bit and big-endian platforms, and those with more
"esoteric" API's (do any of the platforms not have poll()?).
- similar changes to Makefile.am's.
- common.h: add statement to include sys/poll.h
- runcmd.c: exit STATE_UNKNOWN if execve() fails.
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1386 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r-- | plugins/Makefile.am | 10 |
1 files changed, 7 insertions, 3 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am index dc01ff2..183f4f1 100644 --- a/plugins/Makefile.am +++ b/plugins/Makefile.am | |||
@@ -13,8 +13,8 @@ LIBS = @LIBINTL@ @LIBS@ @SSLLIBS@ | |||
13 | MATHLIBS = @MATHLIBS@ | 13 | MATHLIBS = @MATHLIBS@ |
14 | AM_CFLAGS = -Wall | 14 | AM_CFLAGS = -Wall |
15 | 15 | ||
16 | libexec_PROGRAMS = check_disk check_dummy check_http check_load \ | 16 | libexec_PROGRAMS = check_apt check_disk check_dummy check_http check_load \ |
17 | check_mrtg check_mrtgtraf check_nwstat check_overcr check_ping \ | 17 | check_mrtg check_mrtgtraf check_ntp check_nwstat check_overcr check_ping \ |
18 | check_real check_smtp check_ssh check_tcp check_time \ | 18 | check_real check_smtp check_ssh check_tcp check_time \ |
19 | check_udp check_ups check_users negate \ | 19 | check_udp check_ups check_users negate \ |
20 | urlize @EXTRAS@ | 20 | urlize @EXTRAS@ |
@@ -25,7 +25,7 @@ check_tcp_programs = check_ftp check_imap check_nntp check_pop \ | |||
25 | EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \ | 25 | EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \ |
26 | check_swap check_fping check_ldap check_game check_dig \ | 26 | check_swap check_fping check_ldap check_game check_dig \ |
27 | check_nagios check_by_ssh check_dns check_nt check_ide_smart \ | 27 | check_nagios check_by_ssh check_dns check_nt check_ide_smart \ |
28 | check_procs check_mysql_query | 28 | check_procs check_mysql_query check_apt |
29 | 29 | ||
30 | EXTRA_DIST = t utils.c netutils.c sslutils.c popen.c utils.h netutils.h \ | 30 | EXTRA_DIST = t utils.c netutils.c sslutils.c popen.c utils.h netutils.h \ |
31 | popen.h common.h getaddrinfo.c getaddrinfo.h \ | 31 | popen.h common.h getaddrinfo.c getaddrinfo.h \ |
@@ -51,6 +51,7 @@ AM_INSTALL_PROGRAM_FLAGS = @INSTALL_OPTS@ | |||
51 | ############################################################################## | 51 | ############################################################################## |
52 | # the actual targets | 52 | # the actual targets |
53 | 53 | ||
54 | check_apt_LDADD = $(BASEOBJS) runcmd.o | ||
54 | check_dig_LDADD = $(NETLIBS) runcmd.o | 55 | check_dig_LDADD = $(NETLIBS) runcmd.o |
55 | check_disk_LDADD = $(BASEOBJS) popen.o | 56 | check_disk_LDADD = $(BASEOBJS) popen.o |
56 | check_dns_LDADD = $(NETLIBS) runcmd.o | 57 | check_dns_LDADD = $(NETLIBS) runcmd.o |
@@ -71,6 +72,7 @@ check_mysql_query_CPPFLAGS = $(MYSQLINCLUDE) | |||
71 | check_mysql_query_LDADD = $(NETLIBS) $(MYSQLLIBS) | 72 | check_mysql_query_LDADD = $(NETLIBS) $(MYSQLLIBS) |
72 | check_nagios_LDADD = $(BASEOBJS) runcmd.o | 73 | check_nagios_LDADD = $(BASEOBJS) runcmd.o |
73 | check_nt_LDADD = $(NETLIBS) | 74 | check_nt_LDADD = $(NETLIBS) |
75 | check_ntp_LDADD = $(NETLIBS) $(MATHLIBS) | ||
74 | check_nwstat_LDADD = $(NETLIBS) | 76 | check_nwstat_LDADD = $(NETLIBS) |
75 | check_overcr_LDADD = $(NETLIBS) | 77 | check_overcr_LDADD = $(NETLIBS) |
76 | check_pgsql_LDADD = $(NETLIBS) $(PGLIBS) | 78 | check_pgsql_LDADD = $(NETLIBS) $(PGLIBS) |
@@ -92,6 +94,7 @@ check_ide_smart_LDADD = $(BASEOBJS) | |||
92 | negate_LDADD = $(BASEOBJS) popen.o | 94 | negate_LDADD = $(BASEOBJS) popen.o |
93 | urlize_LDADD = $(BASEOBJS) popen.o | 95 | urlize_LDADD = $(BASEOBJS) popen.o |
94 | 96 | ||
97 | check_apt_DEPENDENCIES = check_apt.c $(BASEOBJS) runcmd.o $(DEPLIBS) | ||
95 | check_dig_DEPENDENCIES = check_dig.c $(NETOBJS) runcmd.o $(DEPLIBS) | 98 | check_dig_DEPENDENCIES = check_dig.c $(NETOBJS) runcmd.o $(DEPLIBS) |
96 | check_disk_DEPENDENCIES = check_disk.c $(BASEOBJS) popen.o $(DEPLIBS) | 99 | check_disk_DEPENDENCIES = check_disk.c $(BASEOBJS) popen.o $(DEPLIBS) |
97 | check_dns_DEPENDENCIES = check_dns.c $(NETOBJS) runcmd.o $(DEPLIBS) | 100 | check_dns_DEPENDENCIES = check_dns.c $(NETOBJS) runcmd.o $(DEPLIBS) |
@@ -109,6 +112,7 @@ check_mysql_DEPENDENCIES = check_mysql.c $(NETOBJS) $(DEPLIBS) | |||
109 | check_mysql_query_DEPENDENCIES = check_mysql_query.c $(NETOBJS) $(DEPLIBS) | 112 | check_mysql_query_DEPENDENCIES = check_mysql_query.c $(NETOBJS) $(DEPLIBS) |
110 | check_nagios_DEPENDENCIES = check_nagios.c $(BASEOBJS) runcmd.o $(DEPLIBS) | 113 | check_nagios_DEPENDENCIES = check_nagios.c $(BASEOBJS) runcmd.o $(DEPLIBS) |
111 | check_nt_DEPENDENCIES = check_nt.c $(NETOBJS) $(DEPLIBS) | 114 | check_nt_DEPENDENCIES = check_nt.c $(NETOBJS) $(DEPLIBS) |
115 | check_ntp_DEPENDENCIES = check_ntp.c $(NETOBJS) $(DEPLIBS) | ||
112 | check_nwstat_DEPENDENCIES = check_nwstat.c $(NETOBJS) $(DEPLIBS) | 116 | check_nwstat_DEPENDENCIES = check_nwstat.c $(NETOBJS) $(DEPLIBS) |
113 | check_overcr_DEPENDENCIES = check_overcr.c $(NETOBJS) $(DEPLIBS) | 117 | check_overcr_DEPENDENCIES = check_overcr.c $(NETOBJS) $(DEPLIBS) |
114 | check_pgsql_DEPENDENCIES = check_pgsql.c $(NETOBJS) $(DEPLIBS) | 118 | check_pgsql_DEPENDENCIES = check_pgsql.c $(NETOBJS) $(DEPLIBS) |