summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index b6e5f2e..cbca5d7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,7 @@ localedir = $(datadir)/locale
16DEFS = -DLOCALEDIR=\"$(localedir)\" 16DEFS = -DLOCALEDIR=\"$(localedir)\"
17 17
18dist-hook: 18dist-hook:
19 make THANKS nagios-plugins.spec pkg/fedora/nagios-plugins.spec 19 $(MAKE) THANKS
20 echo ${VERSION} >$(distdir)/release 20 echo ${VERSION} >$(distdir)/release
21 21
22install-root: 22install-root:
@@ -28,13 +28,6 @@ test test-debug:
28 cd plugins && $(MAKE) $@ 28 cd plugins && $(MAKE) $@
29 cd plugins-scripts && $(MAKE) $@ 29 cd plugins-scripts && $(MAKE) $@
30 30
31nagios-plugins.spec: nagios-plugins.spec.in
32 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@
33
34pkg/fedora/nagios-plugins.spec: nagios-plugins.spec.in
35 $(top_srcdir)/mkinstalldirs pkg/fedora
36 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;/^# Requires$$/r $(top_srcdir)/pkg/fedora/requires" $? > $@
37
38# Solaris pkgmk 31# Solaris pkgmk
39BUILDDIR = build-solaris 32BUILDDIR = build-solaris
40PACKDIR = build-pkg 33PACKDIR = build-pkg
@@ -45,7 +38,9 @@ solpkg:
45 if [ ! -d $(PACKDIR) ] ; then mkdir $(PACKDIR); fi 38 if [ ! -d $(PACKDIR) ] ; then mkdir $(PACKDIR); fi
46 $(MAKE) all 39 $(MAKE) all
47 $(MAKE) DESTDIR=$$PWD/$(BUILDDIR) install 40 $(MAKE) DESTDIR=$$PWD/$(BUILDDIR) install
41 $(INSTALL) plugins-root/pst3 $(BUILDDIR)$(libexecdir)
48 $(INSTALL) pkg/solaris/pkginfo $(BUILDDIR) 42 $(INSTALL) pkg/solaris/pkginfo $(BUILDDIR)
43 $(INSTALL) pkg/solaris/preinstall $(BUILDDIR)
49 cd $(BUILDDIR) && $(PERL) ../$(PKGSCRIPT) ../$(PACKDIR) 44 cd $(BUILDDIR) && $(PERL) ../$(PKGSCRIPT) ../$(PACKDIR)
50 45
51THANKS: THANKS.in 46THANKS: THANKS.in