diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 53 |
1 files changed, 51 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac index bf12995..7c17dcd 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,6 +1,6 @@ | |||
1 | dnl Process this file with autoconf to produce a configure script. | 1 | dnl Process this file with autoconf to produce a configure script. |
2 | AC_PREREQ(2.59) | 2 | AC_PREREQ(2.59) |
3 | AC_INIT(monitoring-plugins,2.2) | 3 | AC_INIT(monitoring-plugins,2.3git) |
4 | AC_CONFIG_SRCDIR(NPTest.pm) | 4 | AC_CONFIG_SRCDIR(NPTest.pm) |
5 | AC_CONFIG_FILES([gl/Makefile]) | 5 | AC_CONFIG_FILES([gl/Makefile]) |
6 | AC_CONFIG_AUX_DIR(build-aux) | 6 | AC_CONFIG_AUX_DIR(build-aux) |
@@ -385,6 +385,42 @@ if test "$ac_cv_header_wtsapi32_h" = "yes"; then | |||
385 | AC_SUBST(WTSAPI32LIBS) | 385 | AC_SUBST(WTSAPI32LIBS) |
386 | fi | 386 | fi |
387 | 387 | ||
388 | _can_enable_check_curl=no | ||
389 | dnl Check for cURL library | ||
390 | LIBCURL_CHECK_CONFIG(yes, 7.15.2, [ | ||
391 | _can_enable_check_curl=yes | ||
392 | LIBCURLINCLUDE="$LIBCURL_CPPFLAGS" | ||
393 | LIBCURLLIBS="$LIBCURL" | ||
394 | LIBCURLCFLAGS="$LIBCURL_CPPFLAGS" | ||
395 | AC_SUBST(LIBCURLINCLUDE) | ||
396 | AC_SUBST(LIBCURLLIBS) | ||
397 | AC_SUBST(LIBCURLCFLAGS) | ||
398 | ], [ | ||
399 | _can_enable_check_curl=no | ||
400 | AC_MSG_WARN([Skipping curl plugin]) | ||
401 | AC_MSG_WARN([install libcurl libs to compile this plugin (see REQUIREMENTS).]) | ||
402 | ]) | ||
403 | |||
404 | dnl Check for uriparser library | ||
405 | URIPARSER_CHECK(yes, 0.7.5, [ | ||
406 | URIPARSERINCLUDE="$URIPARSER_CPPFLAGS" | ||
407 | URIPARSERLIBS="$URIPARSER" | ||
408 | URIPARSERCFLAGS="$URIPARSER_CPPFLAGS" | ||
409 | AC_SUBST(URIPARSERINCLUDE) | ||
410 | AC_SUBST(URIPARSERLIBS) | ||
411 | AC_SUBST(URIPARSERCFLAGS) | ||
412 | ], [ | ||
413 | _can_enable_check_curl=no | ||
414 | AC_MSG_WARN([Skipping curl plugin]) | ||
415 | AC_MSG_WARN([install the uriparser library to compile this plugin (see REQUIREMENTS).]) | ||
416 | ]) | ||
417 | |||
418 | dnl prerequisites met, enable the plugin | ||
419 | if test x$_can_enable_check_curl = xyes; then | ||
420 | EXTRAS="$EXTRAS check_curl\$(EXEEXT)" | ||
421 | fi | ||
422 | AC_CONFIG_FILES([plugins/picohttpparser/Makefile]) | ||
423 | |||
388 | dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface | 424 | dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface |
389 | if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no" | 425 | if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no" |
390 | then | 426 | then |
@@ -1016,6 +1052,10 @@ if test -n "$ac_cv_ps_varlist" ; then | |||
1016 | AC_DEFINE(PS_USES_PROCETIME,"yes", | 1052 | AC_DEFINE(PS_USES_PROCETIME,"yes", |
1017 | [Whether the ps utility uses the "procetime" field]) | 1053 | [Whether the ps utility uses the "procetime" field]) |
1018 | fi | 1054 | fi |
1055 | if echo "$ac_cv_ps_varlist" | grep "procpcpu" >/dev/null; then | ||
1056 | AC_DEFINE(PS_USES_PROCPCPU,"yes", | ||
1057 | [Whether the ps utility uses the "procpcpu" field]) | ||
1058 | fi | ||
1019 | fi | 1059 | fi |
1020 | 1060 | ||
1021 | AC_PATH_PROG(PATH_TO_PING,ping) | 1061 | AC_PATH_PROG(PATH_TO_PING,ping) |
@@ -1060,6 +1100,14 @@ then | |||
1060 | ac_cv_ping_packets_first=yes | 1100 | ac_cv_ping_packets_first=yes |
1061 | AC_MSG_RESULT([$with_ping_command]) | 1101 | AC_MSG_RESULT([$with_ping_command]) |
1062 | 1102 | ||
1103 | elif $PATH_TO_PING -4 -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \ | ||
1104 | egrep -i "^round-trip|^rtt" >/dev/null | ||
1105 | then | ||
1106 | # check if -4 is supported - issue #1550 | ||
1107 | with_ping_command="$PATH_TO_PING -4 -n -U -w %d -c %d %s" | ||
1108 | ac_cv_ping_packets_first=yes | ||
1109 | ac_cv_ping_has_timeout=yes | ||
1110 | AC_MSG_RESULT([$with_ping_command]) | ||
1063 | elif $PATH_TO_PING -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \ | 1111 | elif $PATH_TO_PING -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \ |
1064 | egrep -i "^round-trip|^rtt" >/dev/null | 1112 | egrep -i "^round-trip|^rtt" >/dev/null |
1065 | then | 1113 | then |
@@ -1882,4 +1930,5 @@ ACX_FEATURE([enable],[perl-modules]) | |||
1882 | ACX_FEATURE([with],[cgiurl]) | 1930 | ACX_FEATURE([with],[cgiurl]) |
1883 | ACX_FEATURE([with],[trusted-path]) | 1931 | ACX_FEATURE([with],[trusted-path]) |
1884 | ACX_FEATURE([enable],[libtap]) | 1932 | ACX_FEATURE([enable],[libtap]) |
1885 | 1933 | ACX_FEATURE([with],[libcurl]) | |
1934 | ACX_FEATURE([with],[uriparser]) | ||