diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 39 |
1 files changed, 38 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac index 08a0e78..267c40a 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -385,6 +385,42 @@ if test "$ac_cv_header_wtsapi32_h" = "yes"; then | |||
385 | AC_SUBST(WTSAPI32LIBS) | 385 | AC_SUBST(WTSAPI32LIBS) |
386 | fi | 386 | fi |
387 | 387 | ||
388 | _can_enable_check_curl=no | ||
389 | dnl Check for cURL library | ||
390 | LIBCURL_CHECK_CONFIG(yes, 7.15.2, [ | ||
391 | _can_enable_check_curl=yes | ||
392 | LIBCURLINCLUDE="$LIBCURL_CPPFLAGS" | ||
393 | LIBCURLLIBS="$LIBCURL" | ||
394 | LIBCURLCFLAGS="$LIBCURL_CPPFLAGS" | ||
395 | AC_SUBST(LIBCURLINCLUDE) | ||
396 | AC_SUBST(LIBCURLLIBS) | ||
397 | AC_SUBST(LIBCURLCFLAGS) | ||
398 | ], [ | ||
399 | _can_enable_check_curl=no | ||
400 | AC_MSG_WARN([Skipping curl plugin]) | ||
401 | AC_MSG_WARN([install libcurl libs to compile this plugin (see REQUIREMENTS).]) | ||
402 | ]) | ||
403 | |||
404 | dnl Check for uriparser library | ||
405 | URIPARSER_CHECK(yes, 0.7.5, [ | ||
406 | URIPARSERINCLUDE="$URIPARSER_CPPFLAGS" | ||
407 | URIPARSERLIBS="$URIPARSER" | ||
408 | URIPARSERCFLAGS="$URIPARSER_CPPFLAGS" | ||
409 | AC_SUBST(URIPARSERINCLUDE) | ||
410 | AC_SUBST(URIPARSERLIBS) | ||
411 | AC_SUBST(URIPARSERCFLAGS) | ||
412 | ], [ | ||
413 | _can_enable_check_curl=no | ||
414 | AC_MSG_WARN([Skipping curl plugin]) | ||
415 | AC_MSG_WARN([install the uriparser library to compile this plugin (see REQUIREMENTS).]) | ||
416 | ]) | ||
417 | |||
418 | dnl prerequisites met, enable the plugin | ||
419 | if test x$_can_enable_check_curl = xyes; then | ||
420 | EXTRAS="$EXTRAS check_curl\$(EXEEXT)" | ||
421 | fi | ||
422 | AC_CONFIG_FILES([plugins/picohttpparser/Makefile]) | ||
423 | |||
388 | dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface | 424 | dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface |
389 | if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no" | 425 | if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no" |
390 | then | 426 | then |
@@ -1886,4 +1922,5 @@ ACX_FEATURE([enable],[perl-modules]) | |||
1886 | ACX_FEATURE([with],[cgiurl]) | 1922 | ACX_FEATURE([with],[cgiurl]) |
1887 | ACX_FEATURE([with],[trusted-path]) | 1923 | ACX_FEATURE([with],[trusted-path]) |
1888 | ACX_FEATURE([enable],[libtap]) | 1924 | ACX_FEATURE([enable],[libtap]) |
1889 | 1925 | ACX_FEATURE([with],[libcurl]) | |
1926 | ACX_FEATURE([with],[uriparser]) | ||