diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 35 |
1 files changed, 21 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac index 0a554af6..367e82a6 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -273,26 +273,33 @@ AC_ARG_WITH([radius], [AS_HELP_STRING([--without-radius], [Skips the radius plug | |||
273 | dnl Check for radius libraries | 273 | dnl Check for radius libraries |
274 | AS_IF([test "x$with_radius" != "xno"], [ | 274 | AS_IF([test "x$with_radius" != "xno"], [ |
275 | _SAVEDLIBS="$LIBS" | 275 | _SAVEDLIBS="$LIBS" |
276 | AC_CHECK_LIB(freeradius-client,rc_read_config) | 276 | AC_CHECK_LIB(radcli,rc_read_config) |
277 | if test "$ac_cv_lib_freeradius_client_rc_read_config" = "yes"; then | 277 | if test "$ac_cv_lib_radcli_rc_read_config" = "yes"; then |
278 | EXTRAS="$EXTRAS check_radius\$(EXEEXT)" | 278 | EXTRAS="$EXTRAS check_radius\$(EXEEXT)" |
279 | RADIUSLIBS="-lfreeradius-client" | 279 | RADIUSLIBS="-lradcli" |
280 | AC_SUBST(RADIUSLIBS) | 280 | AC_SUBST(RADIUSLIBS) |
281 | else | 281 | else |
282 | AC_CHECK_LIB(radiusclient-ng,rc_read_config) | 282 | AC_CHECK_LIB(freeradius-client,rc_read_config) |
283 | if test "$ac_cv_lib_radiusclient_ng_rc_read_config" = "yes"; then | 283 | if test "$ac_cv_lib_freeradius_client_rc_read_config" = "yes"; then |
284 | EXTRAS="$EXTRAS check_radius\$(EXEEXT)" | 284 | EXTRAS="$EXTRAS check_radius\$(EXEEXT)" |
285 | RADIUSLIBS="-lradiusclient-ng" | 285 | RADIUSLIBS="-lfreeradius-client" |
286 | AC_SUBST(RADIUSLIBS) | 286 | AC_SUBST(RADIUSLIBS) |
287 | else | 287 | else |
288 | AC_CHECK_LIB(radiusclient,rc_read_config) | 288 | AC_CHECK_LIB(radiusclient-ng,rc_read_config) |
289 | if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then | 289 | if test "$ac_cv_lib_radiusclient_ng_rc_read_config" = "yes"; then |
290 | EXTRAS="$EXTRAS check_radius\$(EXEEXT)" | 290 | EXTRAS="$EXTRAS check_radius\$(EXEEXT)" |
291 | RADIUSLIBS="-lradiusclient" | 291 | RADIUSLIBS="-lradiusclient-ng" |
292 | AC_SUBST(RADIUSLIBS) | 292 | AC_SUBST(RADIUSLIBS) |
293 | else | 293 | else |
294 | AC_MSG_WARN([Skipping radius plugin]) | 294 | AC_CHECK_LIB(radiusclient,rc_read_config) |
295 | AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).]) | 295 | if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then |
296 | EXTRAS="$EXTRAS check_radius\$(EXEEXT)" | ||
297 | RADIUSLIBS="-lradiusclient" | ||
298 | AC_SUBST(RADIUSLIBS) | ||
299 | else | ||
300 | AC_MSG_WARN([Skipping radius plugin]) | ||
301 | AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).]) | ||
302 | fi | ||
296 | fi | 303 | fi |
297 | fi | 304 | fi |
298 | fi | 305 | fi |
@@ -493,15 +500,15 @@ if ! test x"$with_openssl" = x"no"; then | |||
493 | dnl Check for crypto lib | 500 | dnl Check for crypto lib |
494 | _SAVEDLIBS="$LIBS" | 501 | _SAVEDLIBS="$LIBS" |
495 | LIBS="-L${with_openssl}/lib" | 502 | LIBS="-L${with_openssl}/lib" |
496 | AC_CHECK_LIB(crypto,CRYPTO_lock) | 503 | AC_CHECK_LIB(crypto,CRYPTO_new_ex_data) |
497 | if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then | 504 | if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then |
498 | dnl Check for SSL lib | 505 | dnl Check for SSL lib |
499 | AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto) | 506 | AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto) |
500 | fi | 507 | fi |
501 | LIBS="$_SAVEDLIBS" | 508 | LIBS="$_SAVEDLIBS" |
502 | 509 | ||
503 | dnl test headers and libs to decide whether check_http should use SSL | 510 | dnl test headers and libs to decide whether check_http should use SSL |
504 | if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then | 511 | if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then |
505 | if test "$ac_cv_lib_ssl_main" = "yes"; then | 512 | if test "$ac_cv_lib_ssl_main" = "yes"; then |
506 | if test "$FOUNDINCLUDE" = "yes"; then | 513 | if test "$FOUNDINCLUDE" = "yes"; then |
507 | FOUNDOPENSSL="yes" | 514 | FOUNDOPENSSL="yes" |