summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 29 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 0c7169e..a294b00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,6 +328,25 @@ AS_IF([test "x$with_ldap" != "xno"], [
328 LIBS="$_SAVEDLIBS" 328 LIBS="$_SAVEDLIBS"
329]) 329])
330 330
331
332AC_ARG_WITH([systemd], [AS_HELP_STRING([--without-systemd], [Skips systemd support])])
333
334dnl Check for libsystemd
335AS_IF([test "x$with_systemd" != "xno"], [
336 _SAVEDLIBS="$LIBS"
337 AC_CHECK_LIB(systemd,sd_get_sessions,,,-lsystemd)
338 if test "$ac_cv_lib_systemd_sd_get_sessions" = "yes"; then
339 SYSTEMDLIBS="-lsystemd"
340 SYSTEMDINCLUDE=""
341 AC_SUBST(SYSTEMDLIBS)
342 AC_SUBST(SYSTEMDINCLUDE)
343 else
344 AC_MSG_WARN([Skipping systemd support])
345 fi
346 LIBS="$_SAVEDLIBS"
347])
348
349
331dnl Check for headers used by check_ide_smart 350dnl Check for headers used by check_ide_smart
332case $host in 351case $host in
333 *linux*) 352 *linux*)
@@ -932,7 +951,7 @@ elif ps -Ao 's comm vsz rss uid user pid ppid args' 2>/dev/null | \
932then 951then
933 ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]" 952 ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
934 ac_cv_ps_command="$PATH_TO_PS -Ao 's uid pid ppid vsz rss pcpu comm args'" 953 ac_cv_ps_command="$PATH_TO_PS -Ao 's uid pid ppid vsz rss pcpu comm args'"
935 # There must be no space between the %s and %n due to a wierd problem in sscanf where 954 # There must be no space between the %s and %n due to a weird problem in sscanf where
936 # it will return %n as longer than the line length 955 # it will return %n as longer than the line length
937 ac_cv_ps_format="%s %d %d %d %d %d %f %s%n" 956 ac_cv_ps_format="%s %d %d %d %d %d %f %s%n"
938 ac_cv_ps_cols=9 957 ac_cv_ps_cols=9
@@ -1552,7 +1571,7 @@ if test -n "$PATH_TO_SUDO"
1552then 1571then
1553 AC_DEFINE_UNQUOTED(PATH_TO_SUDO,"$PATH_TO_SUDO",[path to sudo]) 1572 AC_DEFINE_UNQUOTED(PATH_TO_SUDO,"$PATH_TO_SUDO",[path to sudo])
1554else 1573else
1555 AC_MSG_WARN([Could not find sudo or eqivalent]) 1574 AC_MSG_WARN([Could not find sudo or equivalent])
1556fi 1575fi
1557 1576
1558AC_PATH_PROG(PATH_TO_MAILQ,mailq) 1577AC_PATH_PROG(PATH_TO_MAILQ,mailq)
@@ -1563,7 +1582,7 @@ if test -n "$PATH_TO_MAILQ"
1563then 1582then
1564 AC_DEFINE_UNQUOTED(PATH_TO_MAILQ,"$PATH_TO_MAILQ",[path to mailq]) 1583 AC_DEFINE_UNQUOTED(PATH_TO_MAILQ,"$PATH_TO_MAILQ",[path to mailq])
1565else 1584else
1566 AC_MSG_WARN([Could not find mailq or eqivalent]) 1585 AC_MSG_WARN([Could not find mailq or equivalent])
1567fi 1586fi
1568 1587
1569AC_PATH_PROG(PATH_TO_QMAIL_QSTAT,qmail-qstat) 1588AC_PATH_PROG(PATH_TO_QMAIL_QSTAT,qmail-qstat)
@@ -1574,7 +1593,7 @@ if test -n "$PATH_TO_QMAIL_QSTAT"
1574then 1593then
1575 AC_DEFINE_UNQUOTED(PATH_TO_QMAIL_QSTAT,"$PATH_TO_QMAIL_QSTAT",[path to qmail-qstat]) 1594 AC_DEFINE_UNQUOTED(PATH_TO_QMAIL_QSTAT,"$PATH_TO_QMAIL_QSTAT",[path to qmail-qstat])
1576else 1595else
1577 AC_MSG_WARN([Could not find qmail-qstat or eqivalent]) 1596 AC_MSG_WARN([Could not find qmail-qstat or equivalent])
1578fi 1597fi
1579 1598
1580dnl SWAP info required is amount allocated/available and amount free 1599dnl SWAP info required is amount allocated/available and amount free
@@ -1592,13 +1611,13 @@ then
1592 grep -E -i "^lswap +path +pri +swaplo +blocks +free +maxswap" \ 1611 grep -E -i "^lswap +path +pri +swaplo +blocks +free +maxswap" \
1593 >/dev/null] 1612 >/dev/null]
1594 then 1613 then
1595 ac_cv_swap_format=[" %*d %*s %*d,%*d %*d %*d %f %f"] 1614 ac_cv_swap_format=[" %*d %*s %*d,%*d %*d %*d %lu %lu"]
1596 ac_cv_swap_conv=2048 1615 ac_cv_swap_conv=2048
1597 AC_MSG_RESULT([using IRIX format swap]) 1616 AC_MSG_RESULT([using IRIX format swap])
1598 1617
1599 elif [$PATH_TO_SWAP -l 2>/dev/null | grep -E -i "^path +dev +swaplo +blocks +free" >/dev/null] 1618 elif [$PATH_TO_SWAP -l 2>/dev/null | grep -E -i "^path +dev +swaplo +blocks +free" >/dev/null]
1600 then 1619 then
1601 ac_cv_swap_format=["%*s %*[0-9,-] %*d %f %f"] 1620 ac_cv_swap_format=["%*s %*[0-9,-] %*d %lu %lu"]
1602 ac_cv_swap_conv=2048 1621 ac_cv_swap_conv=2048
1603 AC_MSG_RESULT([using Unixware format swap]) 1622 AC_MSG_RESULT([using Unixware format swap])
1604 else 1623 else
@@ -1622,7 +1641,7 @@ then
1622 1641
1623 if [$PATH_TO_SWAPINFO -k 2>/dev/null | grep -E -i "^Device +1K-blocks +Used +Avail" >/dev/null] 1642 if [$PATH_TO_SWAPINFO -k 2>/dev/null | grep -E -i "^Device +1K-blocks +Used +Avail" >/dev/null]
1624 then 1643 then
1625 ac_cv_swap_format=["%*s %f %*d %f"] 1644 ac_cv_swap_format=["%*s %lu %*d %lu"]
1626 ac_cv_swap_conv=1024 1645 ac_cv_swap_conv=1024
1627 AC_MSG_RESULT([using FreeBSD format swapinfo]) 1646 AC_MSG_RESULT([using FreeBSD format swapinfo])
1628 fi 1647 fi
@@ -1631,7 +1650,7 @@ elif [$PATH_TO_SWAPINFO -dfM 2>/dev/null | grep -E -i "^TYPE +AVAIL +USED +FREE"
1631then 1650then
1632 ac_cv_have_swap=yes 1651 ac_cv_have_swap=yes
1633 ac_cv_swap_command="$PATH_TO_SWAPINFO -dfM" 1652 ac_cv_swap_command="$PATH_TO_SWAPINFO -dfM"
1634 ac_cv_swap_format=["%*s %f %*d %f"] 1653 ac_cv_swap_format=["%*s %lu %*d %lu"]
1635 ac_cv_swap_conv=1024 1654 ac_cv_swap_conv=1024
1636 AC_MSG_RESULT([using HP-UX format swapinfo]) 1655 AC_MSG_RESULT([using HP-UX format swapinfo])
1637fi 1656fi
@@ -1646,7 +1665,7 @@ if [$PATH_TO_LSPS -a 2>/dev/null | grep -E -i "^Page Space" > /dev/null]
1646then 1665then
1647 ac_cv_have_swap=yes 1666 ac_cv_have_swap=yes
1648 ac_cv_swap_command="$PATH_TO_LSPS -a" 1667 ac_cv_swap_command="$PATH_TO_LSPS -a"
1649 ac_cv_swap_format=["%*s %*s %*s %f%*s %f %*s"] 1668 ac_cv_swap_format=["%*s %*s %*s %lu%*s %lu %*s"]
1650 ac_cv_swap_conv=1 1669 ac_cv_swap_conv=1
1651 AC_MSG_RESULT([using AIX lsps]) 1670 AC_MSG_RESULT([using AIX lsps])
1652fi 1671fi
@@ -1832,7 +1851,7 @@ AM_GNU_GETTEXT([external], [need-ngettext])
1832AM_GNU_GETTEXT_VERSION(0.15) 1851AM_GNU_GETTEXT_VERSION(0.15)
1833 1852
1834dnl Check for Redhat spopen problem 1853dnl Check for Redhat spopen problem
1835dnl Wierd problem where ECHILD is returned from a wait call in error 1854dnl Weird problem where ECHILD is returned from a wait call in error
1836dnl Only appears to affect nslookup and dig calls. Only affects redhat around 1855dnl Only appears to affect nslookup and dig calls. Only affects redhat around
1837dnl 2.6.9-11 (okay in 2.6.9-5). Redhat investigating root cause 1856dnl 2.6.9-11 (okay in 2.6.9-5). Redhat investigating root cause
1838dnl We patch plugins/popen.c 1857dnl We patch plugins/popen.c