diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.in b/configure.in index 9067978a..474522d4 100644 --- a/configure.in +++ b/configure.in | |||
@@ -40,6 +40,39 @@ INSTALL="$INSTALL $extra_install_args" | |||
40 | INSTALL_STRIP_PROGRAM="$INSTALL_STRIP_PROGRAM $extra_install_args" | 40 | INSTALL_STRIP_PROGRAM="$INSTALL_STRIP_PROGRAM $extra_install_args" |
41 | AC_SUBST(INSTALL) | 41 | AC_SUBST(INSTALL) |
42 | 42 | ||
43 | dnl Configure the plugin output format | ||
44 | default_output_format="%s %x: %i\n" | ||
45 | AC_ARG_WITH([standard_output_format], | ||
46 | [AS_HELP_STRING([--with-standard-output-format=FORMAT], | ||
47 | [specify the standard plugin output FORMAT; %p, %s, %x, and %m | ||
48 | will be replaced by the plugin name, the service name, the | ||
49 | status string, and the information message, respectively; tabs | ||
50 | or newlines can be inserted using \t or \n | ||
51 | @<:@default="%s %x: %m\n"@:>@])], | ||
52 | [standard_output_format=$withval], | ||
53 | [standard_output_format="yes"]) | ||
54 | AC_ARG_WITH([verbose_output_format], | ||
55 | [AS_HELP_STRING([--with-verbose-output-format=FORMAT], | ||
56 | [specify the verbose plugin output FORMAT; %p, %s, %x, and %m | ||
57 | will be replaced by the plugin name, the service name, the | ||
58 | status string, and the information message, respectively; tabs | ||
59 | or newlines can be inserted using \t or \n | ||
60 | @<:@default="%s %x: %m\n"@:>@])], | ||
61 | [verbose_output_format=$withval], | ||
62 | [verbose_output_format="yes"]) | ||
63 | AS_IF([test "$standard_output_format" = yes], | ||
64 | [standard_output_format=$default_output_format], | ||
65 | [test "$standard_output_format" = no], | ||
66 | [standard_output_format=""], | ||
67 | [test "$verbose_output_format" = yes], | ||
68 | [verbose_output_format=$default_output_format], | ||
69 | [test "$verbose_output_format" = no], | ||
70 | [verbose_output_format=""]) | ||
71 | AC_DEFINE_UNQUOTED([STANDARD_OUTPUT_FORMAT], ["$standard_output_format"], | ||
72 | [Define the standard plugin output format.]) | ||
73 | AC_DEFINE_UNQUOTED([VERBOSE_OUTPUT_FORMAT], ["$verbose_output_format"], | ||
74 | [Define the verbose plugin output format.]) | ||
75 | |||
43 | AC_PROG_CC | 76 | AC_PROG_CC |
44 | gl_EARLY | 77 | gl_EARLY |
45 | AC_PROG_GCC_TRADITIONAL | 78 | AC_PROG_GCC_TRADITIONAL |
@@ -147,6 +180,11 @@ AC_CHECK_LIB(socket,socket,SOCKETLIBS="$SOCKETLIBS -lsocket") | |||
147 | AC_CHECK_LIB(resolv,main,SOCKETLIBS="$SOCKETLIBS -lresolv") | 180 | AC_CHECK_LIB(resolv,main,SOCKETLIBS="$SOCKETLIBS -lresolv") |
148 | AC_SUBST(SOCKETLIBS) | 181 | AC_SUBST(SOCKETLIBS) |
149 | 182 | ||
183 | dnl check for basename(3) which needs -lgen on some systems (e.g. IRIX) | ||
184 | AC_CHECK_HEADERS([libgen.h]) | ||
185 | AC_SEARCH_LIBS([basename], [gen]) | ||
186 | AC_CHECK_FUNCS([basename]) | ||
187 | |||
150 | dnl | 188 | dnl |
151 | dnl check for math-related functions needing -lm | 189 | dnl check for math-related functions needing -lm |
152 | AC_CHECK_HEADERS(math.h) | 190 | AC_CHECK_HEADERS(math.h) |