summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ec3606e..eea01da 100644
--- a/configure.in
+++ b/configure.in
@@ -386,7 +386,7 @@ else
386 if test x$enable_emulate_getaddrinfo != xyes ; then 386 if test x$enable_emulate_getaddrinfo != xyes ; then
387 AC_MSG_ERROR([getaddrinfo not found: try --with-lwres or --enable-emulate-getaddrinfo]) 387 AC_MSG_ERROR([getaddrinfo not found: try --with-lwres or --enable-emulate-getaddrinfo])
388 fi 388 fi
389 LIBOBJS="$LIBOBJS getaddrinfo.o" 389 EXTRA_NETOBJS="$EXTRA_NETOBJS getaddrinfo.o"
390fi 390fi
391 391
392if test x"$enable_emulate_getaddrinfo" != xno ; then 392if test x"$enable_emulate_getaddrinfo" != xno ; then
@@ -414,7 +414,8 @@ if test x"$enable_emulate_getaddrinfo" != xno ; then
414 AC_SEARCH_LIBS(gethostbyname, resolv bind nsl, , 414 AC_SEARCH_LIBS(gethostbyname, resolv bind nsl, ,
415 [AC_MSG_ERROR([cannot find gethostbyname])]) 415 [AC_MSG_ERROR([cannot find gethostbyname])])
416 fi 416 fi
417 LIBOBJS="$LIBOBJS gethostbyname.o" 417 EXTRA_NETOBJS="$EXTRA_NETOBJS gethostbyname.o"
418 AC_DEFINE(EMULATE_GETADDRINFO,1,[Define if emulating getaddrinfo])
418 419
419fi 420fi
420 421
@@ -1451,7 +1452,7 @@ AC_TRY_COMPILE([#ifdef __STDC__
1451 [NEED_VA_LIST=-DNEED_VA_LIST AC_SUBST(NEED_VA_LIST) AC_MSG_RESULT(no)]) 1452 [NEED_VA_LIST=-DNEED_VA_LIST AC_SUBST(NEED_VA_LIST) AC_MSG_RESULT(no)])
1452 1453
1453AC_SUBST(EXTRAS) 1454AC_SUBST(EXTRAS)
1454AC_SUBST(LIBOBJS) 1455AC_SUBST(EXTRA_NETOBJS)
1455AC_SUBST(DEPLIBS) 1456AC_SUBST(DEPLIBS)
1456 1457
1457AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version]) 1458AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version])