diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 14 |
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.in b/configure.in index 030b1de..d6ea4d3 100644 --- a/configure.in +++ b/configure.in | |||
@@ -419,15 +419,17 @@ AC_HELP_STRING([--with-openssl=DIR], [sets path to openssl installation]) | |||
419 | AC_HELP_STRING([--without-openssl], [disable openssl]), | 419 | AC_HELP_STRING([--without-openssl], [disable openssl]), |
420 | OPENSSL=$withval) | 420 | OPENSSL=$withval) |
421 | 421 | ||
422 | _SAVEDCPPFLAGS="$CPPFLAGS" | ||
423 | _SAVEDLDFLAGS="$LDFLAGS" | ||
422 | if test X"$OPENSSL" = "Xno"; then | 424 | if test X"$OPENSSL" = "Xno"; then |
423 | AC_MSG_WARN([openssl disabled, you will not be able to use ssl options in some plugins]) | 425 | AC_MSG_WARN([openssl disabled, you will not be able to use ssl options in some plugins]) |
424 | FOUNDSSL="dontbother" | 426 | FOUNDSSL="dontbother" |
425 | else | 427 | else |
426 | dnl Check for OpenSSL header files | 428 | dnl Check for OpenSSL header files |
427 | unset FOUNDINCLUDE | 429 | unset FOUNDINCLUDE |
428 | _SAVEDCPPFLAGS="$CPPFLAGS" | ||
429 | if test "$OPENSSL" != "/usr"; then | 430 | if test "$OPENSSL" != "/usr"; then |
430 | CPPFLAGS="$CPPFLAGS -I$OPENSSL/include" | 431 | CPPFLAGS="$CPPFLAGS -I$OPENSSL/include" |
432 | LDFLAGS="$LDFLAGS -R$OPENSSL/lib" | ||
431 | fi | 433 | fi |
432 | AC_CHECK_HEADERS(openssl/ssl.h openssl/x509.h openssl/rsa.h openssl/pem.h openssl/crypto.h openssl/err.h, | 434 | AC_CHECK_HEADERS(openssl/ssl.h openssl/x509.h openssl/rsa.h openssl/pem.h openssl/crypto.h openssl/err.h, |
433 | SSLINCLUDE="-I$OPENSSL/include" | 435 | SSLINCLUDE="-I$OPENSSL/include" |
@@ -470,13 +472,15 @@ if test "$FOUNDSSL" = "yes"; then | |||
470 | AC_SUBST(SSLLIBS) | 472 | AC_SUBST(SSLLIBS) |
471 | AC_DEFINE(HAVE_SSL,1,[Define if SSL libraries are found]) | 473 | AC_DEFINE(HAVE_SSL,1,[Define if SSL libraries are found]) |
472 | with_openssl="yes" | 474 | with_openssl="yes" |
473 | elif test "$FOUNDSSL" = "no"; then | ||
474 | AC_MSG_WARN([OpenSSL libs could not be found]) | ||
475 | with_openssl="no" | ||
476 | else | 475 | else |
476 | if test "$FOUNDSSL" = "no"; then | ||
477 | AC_MSG_WARN([OpenSSL libs could not be found]) | ||
478 | dnl else deliberately disabled | ||
479 | fi | ||
477 | with_openssl="no" | 480 | with_openssl="no" |
481 | CPPFLAGS="$_SAVEDCPPFLAGS" | ||
482 | LDFLAGS="$_SAVEDLDFLAGS" | ||
478 | fi | 483 | fi |
479 | CPPFLAGS="$_SAVEDCPPFLAGS" | ||
480 | 484 | ||
481 | dnl | 485 | dnl |
482 | dnl Checks for header files. | 486 | dnl Checks for header files. |