diff options
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r-- | gl/Makefile.am | 607 |
1 files changed, 607 insertions, 0 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am new file mode 100644 index 0000000..67c9872 --- /dev/null +++ b/gl/Makefile.am | |||
@@ -0,0 +1,607 @@ | |||
1 | ## DO NOT EDIT! GENERATED AUTOMATICALLY! | ||
2 | ## Process this file with automake to produce Makefile.in. | ||
3 | # Copyright (C) 2004-2007 Free Software Foundation, Inc. | ||
4 | # | ||
5 | # This file is free software, distributed under the terms of the GNU | ||
6 | # General Public License. As a special exception to the GNU General | ||
7 | # Public License, this file may be distributed as part of a program | ||
8 | # that contains a configuration script generated by Autoconf, under | ||
9 | # the same distribution terms as the rest of that program. | ||
10 | # | ||
11 | # Generated by gnulib-tool. | ||
12 | # Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --aux-dir=. --no-libtool --macro-prefix=gl dirname fsusage getaddrinfo gethostname getloadavg getopt gettext mountlist regex vasprintf vsnprintf | ||
13 | |||
14 | AUTOMAKE_OPTIONS = 1.5 gnits | ||
15 | |||
16 | noinst_HEADERS = | ||
17 | noinst_LIBRARIES = | ||
18 | noinst_LTLIBRARIES = | ||
19 | EXTRA_DIST = | ||
20 | BUILT_SOURCES = | ||
21 | SUFFIXES = | ||
22 | MOSTLYCLEANFILES = core *.stackdump | ||
23 | MOSTLYCLEANDIRS = | ||
24 | CLEANFILES = | ||
25 | DISTCLEANFILES = | ||
26 | MAINTAINERCLEANFILES = | ||
27 | |||
28 | AM_CPPFLAGS = | ||
29 | |||
30 | noinst_LIBRARIES += libgnu.a | ||
31 | |||
32 | libgnu_a_SOURCES = | ||
33 | libgnu_a_LIBADD = $(gl_LIBOBJS) | ||
34 | libgnu_a_DEPENDENCIES = $(gl_LIBOBJS) | ||
35 | EXTRA_libgnu_a_SOURCES = | ||
36 | |||
37 | ## begin gnulib module alloca | ||
38 | |||
39 | |||
40 | EXTRA_DIST += alloca.c | ||
41 | |||
42 | EXTRA_libgnu_a_SOURCES += alloca.c | ||
43 | |||
44 | libgnu_a_LIBADD += @ALLOCA@ | ||
45 | libgnu_a_DEPENDENCIES += @ALLOCA@ | ||
46 | ## end gnulib module alloca | ||
47 | |||
48 | ## begin gnulib module alloca-opt | ||
49 | |||
50 | BUILT_SOURCES += $(ALLOCA_H) | ||
51 | |||
52 | # We need the following in order to create <alloca.h> when the system | ||
53 | # doesn't have one that works with the given compiler. | ||
54 | alloca.h: alloca_.h | ||
55 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
56 | cat $(srcdir)/alloca_.h; \ | ||
57 | } > $@-t | ||
58 | mv -f $@-t $@ | ||
59 | MOSTLYCLEANFILES += alloca.h alloca.h-t | ||
60 | |||
61 | EXTRA_DIST += alloca_.h | ||
62 | |||
63 | ## end gnulib module alloca-opt | ||
64 | |||
65 | ## begin gnulib module arpa_inet | ||
66 | |||
67 | BUILT_SOURCES += $(ARPA_INET_H) | ||
68 | |||
69 | # We need the following in order to create <arpa/inet.h> when the system | ||
70 | # doesn't have one. | ||
71 | arpa/inet.h: | ||
72 | test -d arpa || mkdir arpa | ||
73 | rm -f $@-t $@ | ||
74 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
75 | echo '#include <sys/socket.h>'; \ | ||
76 | } > $@-t | ||
77 | mv $@-t $@ | ||
78 | MOSTLYCLEANFILES += arpa/inet.h arpa/inet.h-t | ||
79 | MOSTLYCLEANDIRS += arpa | ||
80 | |||
81 | ## end gnulib module arpa_inet | ||
82 | |||
83 | ## begin gnulib module c-strtod | ||
84 | |||
85 | |||
86 | EXTRA_DIST += c-strtod.c c-strtod.h | ||
87 | |||
88 | EXTRA_libgnu_a_SOURCES += c-strtod.c | ||
89 | |||
90 | ## end gnulib module c-strtod | ||
91 | |||
92 | ## begin gnulib module cloexec | ||
93 | |||
94 | |||
95 | EXTRA_DIST += cloexec.c cloexec.h | ||
96 | |||
97 | EXTRA_libgnu_a_SOURCES += cloexec.c | ||
98 | |||
99 | ## end gnulib module cloexec | ||
100 | |||
101 | ## begin gnulib module dirname | ||
102 | |||
103 | |||
104 | EXTRA_DIST += basename.c dirname.c dirname.h stripslash.c | ||
105 | |||
106 | EXTRA_libgnu_a_SOURCES += basename.c dirname.c stripslash.c | ||
107 | |||
108 | ## end gnulib module dirname | ||
109 | |||
110 | ## begin gnulib module error | ||
111 | |||
112 | |||
113 | EXTRA_DIST += error.c error.h | ||
114 | |||
115 | EXTRA_libgnu_a_SOURCES += error.c | ||
116 | |||
117 | ## end gnulib module error | ||
118 | |||
119 | ## begin gnulib module exit | ||
120 | |||
121 | libgnu_a_SOURCES += exit.h | ||
122 | |||
123 | ## end gnulib module exit | ||
124 | |||
125 | ## begin gnulib module exitfail | ||
126 | |||
127 | |||
128 | EXTRA_DIST += exitfail.c exitfail.h | ||
129 | |||
130 | EXTRA_libgnu_a_SOURCES += exitfail.c | ||
131 | |||
132 | ## end gnulib module exitfail | ||
133 | |||
134 | ## begin gnulib module fcntl-safer | ||
135 | |||
136 | |||
137 | EXTRA_DIST += creat-safer.c fcntl--.h fcntl-safer.h open-safer.c | ||
138 | |||
139 | EXTRA_libgnu_a_SOURCES += creat-safer.c open-safer.c | ||
140 | |||
141 | ## end gnulib module fcntl-safer | ||
142 | |||
143 | ## begin gnulib module fsusage | ||
144 | |||
145 | |||
146 | EXTRA_DIST += fsusage.c fsusage.h | ||
147 | |||
148 | EXTRA_libgnu_a_SOURCES += fsusage.c | ||
149 | |||
150 | ## end gnulib module fsusage | ||
151 | |||
152 | ## begin gnulib module full-read | ||
153 | |||
154 | libgnu_a_SOURCES += full-read.h full-read.c | ||
155 | |||
156 | ## end gnulib module full-read | ||
157 | |||
158 | ## begin gnulib module full-write | ||
159 | |||
160 | libgnu_a_SOURCES += full-write.h full-write.c | ||
161 | |||
162 | ## end gnulib module full-write | ||
163 | |||
164 | ## begin gnulib module getaddrinfo | ||
165 | |||
166 | |||
167 | EXTRA_DIST += gai_strerror.c getaddrinfo.c getaddrinfo.h | ||
168 | |||
169 | EXTRA_libgnu_a_SOURCES += gai_strerror.c getaddrinfo.c | ||
170 | |||
171 | ## end gnulib module getaddrinfo | ||
172 | |||
173 | ## begin gnulib module gethostname | ||
174 | |||
175 | |||
176 | EXTRA_DIST += gethostname.c | ||
177 | |||
178 | EXTRA_libgnu_a_SOURCES += gethostname.c | ||
179 | |||
180 | ## end gnulib module gethostname | ||
181 | |||
182 | ## begin gnulib module getloadavg | ||
183 | |||
184 | |||
185 | EXTRA_DIST += getloadavg.c | ||
186 | |||
187 | EXTRA_libgnu_a_SOURCES += getloadavg.c | ||
188 | |||
189 | ## end gnulib module getloadavg | ||
190 | |||
191 | ## begin gnulib module getopt | ||
192 | |||
193 | BUILT_SOURCES += $(GETOPT_H) | ||
194 | |||
195 | # We need the following in order to create <getopt.h> when the system | ||
196 | # doesn't have one that works with the given compiler. | ||
197 | getopt.h: getopt_.h | ||
198 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
199 | cat $(srcdir)/getopt_.h; \ | ||
200 | } > $@-t | ||
201 | mv -f $@-t $@ | ||
202 | MOSTLYCLEANFILES += getopt.h getopt.h-t | ||
203 | |||
204 | EXTRA_DIST += getopt.c getopt1.c getopt_.h getopt_int.h | ||
205 | |||
206 | EXTRA_libgnu_a_SOURCES += getopt.c getopt1.c | ||
207 | |||
208 | ## end gnulib module getopt | ||
209 | |||
210 | ## begin gnulib module gettext | ||
211 | |||
212 | # This is for those projects which use "gettextize --intl" to put a source-code | ||
213 | # copy of libintl into their package. In such projects, every Makefile.am needs | ||
214 | # -I$(top_builddir)/intl, so that <libintl.h> can be found in this directory. | ||
215 | # For the Makefile.ams in other directories it is the maintainer's | ||
216 | # responsibility; for the one from gnulib we do it here. | ||
217 | # This option has no effect when the user disables NLS (because then the intl | ||
218 | # directory contains no libintl.h file) or when the project does not use | ||
219 | # "gettextize --intl". | ||
220 | AM_CPPFLAGS += -I$(top_builddir)/intl | ||
221 | |||
222 | ## end gnulib module gettext | ||
223 | |||
224 | ## begin gnulib module gettext-h | ||
225 | |||
226 | libgnu_a_SOURCES += gettext.h | ||
227 | |||
228 | ## end gnulib module gettext-h | ||
229 | |||
230 | ## begin gnulib module inet_ntop | ||
231 | |||
232 | |||
233 | EXTRA_DIST += inet_ntop.c inet_ntop.h | ||
234 | |||
235 | EXTRA_libgnu_a_SOURCES += inet_ntop.c | ||
236 | |||
237 | ## end gnulib module inet_ntop | ||
238 | |||
239 | ## begin gnulib module intprops | ||
240 | |||
241 | |||
242 | EXTRA_DIST += intprops.h | ||
243 | |||
244 | ## end gnulib module intprops | ||
245 | |||
246 | ## begin gnulib module malloc | ||
247 | |||
248 | |||
249 | EXTRA_DIST += malloc.c | ||
250 | |||
251 | EXTRA_libgnu_a_SOURCES += malloc.c | ||
252 | |||
253 | ## end gnulib module malloc | ||
254 | |||
255 | ## begin gnulib module mbchar | ||
256 | |||
257 | |||
258 | EXTRA_DIST += mbchar.c mbchar.h | ||
259 | |||
260 | EXTRA_libgnu_a_SOURCES += mbchar.c | ||
261 | |||
262 | ## end gnulib module mbchar | ||
263 | |||
264 | ## begin gnulib module mbuiter | ||
265 | |||
266 | libgnu_a_SOURCES += mbuiter.h | ||
267 | |||
268 | ## end gnulib module mbuiter | ||
269 | |||
270 | ## begin gnulib module memchr | ||
271 | |||
272 | |||
273 | EXTRA_DIST += memchr.c | ||
274 | |||
275 | EXTRA_libgnu_a_SOURCES += memchr.c | ||
276 | |||
277 | ## end gnulib module memchr | ||
278 | |||
279 | ## begin gnulib module minmax | ||
280 | |||
281 | libgnu_a_SOURCES += minmax.h | ||
282 | |||
283 | ## end gnulib module minmax | ||
284 | |||
285 | ## begin gnulib module mountlist | ||
286 | |||
287 | |||
288 | EXTRA_DIST += mountlist.c mountlist.h | ||
289 | |||
290 | EXTRA_libgnu_a_SOURCES += mountlist.c | ||
291 | |||
292 | ## end gnulib module mountlist | ||
293 | |||
294 | ## begin gnulib module netinet_in | ||
295 | |||
296 | BUILT_SOURCES += $(NETINET_IN_H) | ||
297 | |||
298 | # We need the following in order to create <netinet/in.h> when the system | ||
299 | # doesn't have one. | ||
300 | netinet/in.h: | ||
301 | test -d netinet || mkdir netinet | ||
302 | rm -f $@-t $@ | ||
303 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
304 | echo '#include <sys/socket.h>'; \ | ||
305 | } > $@-t | ||
306 | mv $@-t $@ | ||
307 | MOSTLYCLEANFILES += netinet/in.h netinet/in.h-t | ||
308 | MOSTLYCLEANDIRS += netinet | ||
309 | |||
310 | ## end gnulib module netinet_in | ||
311 | |||
312 | ## begin gnulib module regex | ||
313 | |||
314 | |||
315 | EXTRA_DIST += regcomp.c regex.c regex.h regex_internal.c regex_internal.h regexec.c | ||
316 | |||
317 | EXTRA_libgnu_a_SOURCES += regcomp.c regex.c regex_internal.c regexec.c | ||
318 | |||
319 | ## end gnulib module regex | ||
320 | |||
321 | ## begin gnulib module safe-read | ||
322 | |||
323 | |||
324 | EXTRA_DIST += safe-read.c safe-read.h | ||
325 | |||
326 | EXTRA_libgnu_a_SOURCES += safe-read.c | ||
327 | |||
328 | ## end gnulib module safe-read | ||
329 | |||
330 | ## begin gnulib module safe-write | ||
331 | |||
332 | |||
333 | EXTRA_DIST += safe-write.c safe-write.h | ||
334 | |||
335 | EXTRA_libgnu_a_SOURCES += safe-write.c | ||
336 | |||
337 | ## end gnulib module safe-write | ||
338 | |||
339 | ## begin gnulib module size_max | ||
340 | |||
341 | libgnu_a_SOURCES += size_max.h | ||
342 | |||
343 | ## end gnulib module size_max | ||
344 | |||
345 | ## begin gnulib module snprintf | ||
346 | |||
347 | |||
348 | EXTRA_DIST += snprintf.c snprintf.h | ||
349 | |||
350 | EXTRA_libgnu_a_SOURCES += snprintf.c | ||
351 | |||
352 | ## end gnulib module snprintf | ||
353 | |||
354 | ## begin gnulib module stdbool | ||
355 | |||
356 | BUILT_SOURCES += $(STDBOOL_H) | ||
357 | |||
358 | # We need the following in order to create <stdbool.h> when the system | ||
359 | # doesn't have one that works. | ||
360 | stdbool.h: stdbool_.h | ||
361 | rm -f $@-t $@ | ||
362 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
363 | sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' < $(srcdir)/stdbool_.h; \ | ||
364 | } > $@-t | ||
365 | mv $@-t $@ | ||
366 | MOSTLYCLEANFILES += stdbool.h stdbool.h-t | ||
367 | |||
368 | EXTRA_DIST += stdbool_.h | ||
369 | |||
370 | ## end gnulib module stdbool | ||
371 | |||
372 | ## begin gnulib module stdint | ||
373 | |||
374 | BUILT_SOURCES += $(STDINT_H) | ||
375 | |||
376 | # We need the following in order to create <stdint.h> when the system | ||
377 | # doesn't have one that works with the given compiler. | ||
378 | stdint.h: stdint_.h | ||
379 | rm -f $@-t $@ | ||
380 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
381 | sed -e 's/@''HAVE_STDINT_H''@/$(HAVE_STDINT_H)/g' \ | ||
382 | -e 's|@''ABSOLUTE_STDINT_H''@|$(ABSOLUTE_STDINT_H)|g' \ | ||
383 | -e 's/@''HAVE_SYS_TYPES_H''@/$(HAVE_SYS_TYPES_H)/g' \ | ||
384 | -e 's/@''HAVE_INTTYPES_H''@/$(HAVE_INTTYPES_H)/g' \ | ||
385 | -e 's/@''HAVE_SYS_INTTYPES_H''@/$(HAVE_SYS_INTTYPES_H)/g' \ | ||
386 | -e 's/@''HAVE_SYS_BITYPES_H''@/$(HAVE_SYS_BITYPES_H)/g' \ | ||
387 | -e 's/@''HAVE_LONG_LONG_INT''@/$(HAVE_LONG_LONG_INT)/g' \ | ||
388 | -e 's/@''HAVE_UNSIGNED_LONG_LONG_INT''@/$(HAVE_UNSIGNED_LONG_LONG_INT)/g' \ | ||
389 | -e 's/@''BITSIZEOF_PTRDIFF_T''@/$(BITSIZEOF_PTRDIFF_T)/g' \ | ||
390 | -e 's/@''PTRDIFF_T_SUFFIX''@/$(PTRDIFF_T_SUFFIX)/g' \ | ||
391 | -e 's/@''BITSIZEOF_SIG_ATOMIC_T''@/$(BITSIZEOF_SIG_ATOMIC_T)/g' \ | ||
392 | -e 's/@''HAVE_SIGNED_SIG_ATOMIC_T''@/$(HAVE_SIGNED_SIG_ATOMIC_T)/g' \ | ||
393 | -e 's/@''SIG_ATOMIC_T_SUFFIX''@/$(SIG_ATOMIC_T_SUFFIX)/g' \ | ||
394 | -e 's/@''BITSIZEOF_SIZE_T''@/$(BITSIZEOF_SIZE_T)/g' \ | ||
395 | -e 's/@''SIZE_T_SUFFIX''@/$(SIZE_T_SUFFIX)/g' \ | ||
396 | -e 's/@''BITSIZEOF_WCHAR_T''@/$(BITSIZEOF_WCHAR_T)/g' \ | ||
397 | -e 's/@''HAVE_SIGNED_WCHAR_T''@/$(HAVE_SIGNED_WCHAR_T)/g' \ | ||
398 | -e 's/@''WCHAR_T_SUFFIX''@/$(WCHAR_T_SUFFIX)/g' \ | ||
399 | -e 's/@''BITSIZEOF_WINT_T''@/$(BITSIZEOF_WINT_T)/g' \ | ||
400 | -e 's/@''HAVE_SIGNED_WINT_T''@/$(HAVE_SIGNED_WINT_T)/g' \ | ||
401 | -e 's/@''WINT_T_SUFFIX''@/$(WINT_T_SUFFIX)/g' \ | ||
402 | < $(srcdir)/stdint_.h; \ | ||
403 | } > $@-t | ||
404 | mv $@-t $@ | ||
405 | MOSTLYCLEANFILES += stdint.h stdint.h-t | ||
406 | |||
407 | EXTRA_DIST += stdint_.h | ||
408 | |||
409 | ## end gnulib module stdint | ||
410 | |||
411 | ## begin gnulib module strcase | ||
412 | |||
413 | |||
414 | EXTRA_DIST += strcase.h strcasecmp.c strncasecmp.c | ||
415 | |||
416 | EXTRA_libgnu_a_SOURCES += strcasecmp.c strncasecmp.c | ||
417 | |||
418 | ## end gnulib module strcase | ||
419 | |||
420 | ## begin gnulib module strdup | ||
421 | |||
422 | |||
423 | EXTRA_DIST += strdup.c strdup.h | ||
424 | |||
425 | EXTRA_libgnu_a_SOURCES += strdup.c | ||
426 | |||
427 | ## end gnulib module strdup | ||
428 | |||
429 | ## begin gnulib module strndup | ||
430 | |||
431 | |||
432 | EXTRA_DIST += strndup.c strndup.h | ||
433 | |||
434 | EXTRA_libgnu_a_SOURCES += strndup.c | ||
435 | |||
436 | ## end gnulib module strndup | ||
437 | |||
438 | ## begin gnulib module strnlen | ||
439 | |||
440 | |||
441 | EXTRA_DIST += strnlen.c strnlen.h | ||
442 | |||
443 | EXTRA_libgnu_a_SOURCES += strnlen.c | ||
444 | |||
445 | ## end gnulib module strnlen | ||
446 | |||
447 | ## begin gnulib module strnlen1 | ||
448 | |||
449 | libgnu_a_SOURCES += strnlen1.h strnlen1.c | ||
450 | |||
451 | ## end gnulib module strnlen1 | ||
452 | |||
453 | ## begin gnulib module sys_socket | ||
454 | |||
455 | BUILT_SOURCES += $(SYS_SOCKET_H) | ||
456 | |||
457 | # We need the following in order to create <sys/socket.h> when the system | ||
458 | # doesn't have one that works with the given compiler. | ||
459 | sys/socket.h: socket_.h | ||
460 | @MKDIR_P@ sys | ||
461 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
462 | cat $(srcdir)/socket_.h; \ | ||
463 | } > $@-t | ||
464 | mv -f $@-t $@ | ||
465 | MOSTLYCLEANFILES += sys/socket.h sys/socket.h-t | ||
466 | MOSTLYCLEANDIRS += sys | ||
467 | |||
468 | EXTRA_DIST += socket_.h | ||
469 | |||
470 | ## end gnulib module sys_socket | ||
471 | |||
472 | ## begin gnulib module unistd | ||
473 | |||
474 | BUILT_SOURCES += $(UNISTD_H) | ||
475 | |||
476 | # We need the following in order to create an empty placeholder for | ||
477 | # <unistd.h> when the system doesn't have one. | ||
478 | unistd.h: unistd_.h | ||
479 | rm -f $@-t $@ | ||
480 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
481 | sed -e 's|@''ABSOLUTE_UNISTD_H''@|$(ABSOLUTE_UNISTD_H)|g' \ | ||
482 | < $(srcdir)/unistd_.h; \ | ||
483 | } > $@-t | ||
484 | mv $@-t $@ | ||
485 | MOSTLYCLEANFILES += unistd.h unistd.h-t | ||
486 | |||
487 | EXTRA_DIST += unistd_.h | ||
488 | |||
489 | ## end gnulib module unistd | ||
490 | |||
491 | ## begin gnulib module unistd-safer | ||
492 | |||
493 | |||
494 | EXTRA_DIST += dup-safer.c fd-safer.c pipe-safer.c unistd--.h unistd-safer.h | ||
495 | |||
496 | EXTRA_libgnu_a_SOURCES += dup-safer.c fd-safer.c pipe-safer.c | ||
497 | |||
498 | ## end gnulib module unistd-safer | ||
499 | |||
500 | ## begin gnulib module vasnprintf | ||
501 | |||
502 | |||
503 | EXTRA_DIST += asnprintf.c printf-args.c printf-args.h printf-parse.c printf-parse.h vasnprintf.c vasnprintf.h | ||
504 | |||
505 | EXTRA_libgnu_a_SOURCES += asnprintf.c printf-args.c printf-parse.c vasnprintf.c | ||
506 | |||
507 | ## end gnulib module vasnprintf | ||
508 | |||
509 | ## begin gnulib module vasprintf | ||
510 | |||
511 | |||
512 | EXTRA_DIST += asprintf.c vasprintf.c vasprintf.h | ||
513 | |||
514 | EXTRA_libgnu_a_SOURCES += asprintf.c vasprintf.c | ||
515 | |||
516 | ## end gnulib module vasprintf | ||
517 | |||
518 | ## begin gnulib module vsnprintf | ||
519 | |||
520 | |||
521 | EXTRA_DIST += vsnprintf.c vsnprintf.h | ||
522 | |||
523 | EXTRA_libgnu_a_SOURCES += vsnprintf.c | ||
524 | |||
525 | ## end gnulib module vsnprintf | ||
526 | |||
527 | ## begin gnulib module wchar | ||
528 | |||
529 | BUILT_SOURCES += $(WCHAR_H) | ||
530 | |||
531 | # We need the following in order to create <wchar.h> when the system | ||
532 | # version does not work standalone. | ||
533 | wchar.h: wchar_.h | ||
534 | rm -f $@-t $@ | ||
535 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
536 | sed -e 's|@''ABSOLUTE_WCHAR_H''@|$(ABSOLUTE_WCHAR_H)|g' \ | ||
537 | < $(srcdir)/wchar_.h; \ | ||
538 | } > $@-t | ||
539 | mv $@-t $@ | ||
540 | MOSTLYCLEANFILES += wchar.h wchar.h-t | ||
541 | |||
542 | EXTRA_DIST += wchar_.h | ||
543 | |||
544 | ## end gnulib module wchar | ||
545 | |||
546 | ## begin gnulib module wctype | ||
547 | |||
548 | BUILT_SOURCES += $(WCTYPE_H) | ||
549 | |||
550 | # We need the following in order to create <wctype.h> when the system | ||
551 | # doesn't have one that works with the given compiler. | ||
552 | wctype.h: wctype_.h | ||
553 | rm -f $@-t $@ | ||
554 | { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \ | ||
555 | sed -e 's/@''HAVE_WCTYPE_H''@/$(HAVE_WCTYPE_H)/g' \ | ||
556 | -e 's|@''ABSOLUTE_WCTYPE_H''@|$(ABSOLUTE_WCTYPE_H)|g' \ | ||
557 | -e 's/@''HAVE_WCTYPE_CTMP_BUG''@/$(HAVE_WCTYPE_CTMP_BUG)/g' \ | ||
558 | -e 's/@''HAVE_WINT_T''@/$(HAVE_WINT_T)/g' \ | ||
559 | < $(srcdir)/wctype_.h; \ | ||
560 | } > $@-t | ||
561 | mv $@-t $@ | ||
562 | MOSTLYCLEANFILES += wctype.h wctype.h-t | ||
563 | |||
564 | EXTRA_DIST += wctype_.h | ||
565 | |||
566 | ## end gnulib module wctype | ||
567 | |||
568 | ## begin gnulib module wcwidth | ||
569 | |||
570 | libgnu_a_SOURCES += wcwidth.h | ||
571 | |||
572 | ## end gnulib module wcwidth | ||
573 | |||
574 | ## begin gnulib module xalloc | ||
575 | |||
576 | |||
577 | EXTRA_DIST += xalloc.h xmalloc.c | ||
578 | |||
579 | EXTRA_libgnu_a_SOURCES += xmalloc.c | ||
580 | |||
581 | ## end gnulib module xalloc | ||
582 | |||
583 | ## begin gnulib module xalloc-die | ||
584 | |||
585 | libgnu_a_SOURCES += xalloc-die.c | ||
586 | |||
587 | ## end gnulib module xalloc-die | ||
588 | |||
589 | ## begin gnulib module xsize | ||
590 | |||
591 | libgnu_a_SOURCES += xsize.h | ||
592 | |||
593 | ## end gnulib module xsize | ||
594 | |||
595 | ## begin gnulib module xstrndup | ||
596 | |||
597 | libgnu_a_SOURCES += xstrndup.h xstrndup.c | ||
598 | |||
599 | ## end gnulib module xstrndup | ||
600 | |||
601 | |||
602 | mostlyclean-local: mostlyclean-generic | ||
603 | @for dir in '' $(MOSTLYCLEANDIRS); do \ | ||
604 | if test -n "$$dir" && test -d $$dir; then \ | ||
605 | echo "rmdir $$dir"; rmdir $$dir; \ | ||
606 | fi; \ | ||
607 | done | ||