summaryrefslogtreecommitdiffstats
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
new file mode 100644
index 0000000..63dee76
--- /dev/null
+++ b/lib/tests/Makefile.am
@@ -0,0 +1,28 @@
1
2noinst_PROGRAMS = @EXTRA_TEST@
3
4# These two lines support "make check", but we use "make test"
5TESTS = @EXTRA_TEST@
6check_PROGRAMS = @EXTRA_TEST@
7
8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
9
10EXTRA_PROGRAMS = test_utils test_disk
11
12EXTRA_DIST = test_utils.t test_disk.t
13
14LIBS = @LIBINTL@
15
16test_utils_SOURCES = test_utils.c
17test_utils_CFLAGS = -g -I..
18test_utils_LDFLAGS = -L/usr/local/lib -ltap
19test_utils_LDADD = ../utils_base.o
20
21test_disk_SOURCES = test_disk.c
22test_disk_CFLAGS = -g -I..
23test_disk_LDFLAGS = -L/usr/local/lib -ltap
24test_disk_LDADD = ../utils_disk.o
25
26test: ${noinst_PROGRAMS}
27 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
28