diff options
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r-- | plugins-scripts/Makefile.am | 13 |
1 files changed, 13 insertions, 0 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am index 01fca20..c9e3e40 100644 --- a/plugins-scripts/Makefile.am +++ b/plugins-scripts/Makefile.am | |||
@@ -1,5 +1,11 @@ | |||
1 | ## Process this file with automake to produce Makefile.in | 1 | ## Process this file with automake to produce Makefile.in |
2 | 2 | ||
3 | NP-VERSION-FILE: .FORCE-NP-VERSION-FILE | ||
4 | @$(SHELL_PATH) $(top_srcdir)/NP-VERSION-GEN | ||
5 | -include NP-VERSION-FILE | ||
6 | |||
7 | export NP_VERSION:= $(NP_VERSION) | ||
8 | |||
3 | SUFFIXES = .pl .sh | 9 | SUFFIXES = .pl .sh |
4 | 10 | ||
5 | VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t | 11 | VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t |
@@ -18,6 +24,8 @@ TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir) | |||
18 | 24 | ||
19 | TESTS = @SCRIPT_TEST@ | 25 | TESTS = @SCRIPT_TEST@ |
20 | 26 | ||
27 | all-local: NP-VERSION-FILE | ||
28 | |||
21 | test: | 29 | test: |
22 | perl -I $(top_builddir) -I $(top_srcdir) ../test.pl | 30 | perl -I $(top_builddir) -I $(top_srcdir) ../test.pl |
23 | perl -I $(top_builddir) -I $(top_srcdir) ../test.pl t/utils.t # utils.t is excluded from above, so manually ask to test | 31 | perl -I $(top_builddir) -I $(top_srcdir) ../test.pl t/utils.t # utils.t is excluded from above, so manually ask to test |
@@ -35,3 +43,8 @@ CLEANFILES=$(libexec_SCRIPTS) | |||
35 | .sh : | 43 | .sh : |
36 | $(AWK) -f ./subst $< > $@ | 44 | $(AWK) -f ./subst $< > $@ |
37 | chmod +x $@ | 45 | chmod +x $@ |
46 | |||
47 | clean-local: | ||
48 | rm -f NP-VERSION-FILE | ||
49 | |||
50 | .PHONY: .FORCE-NP-VERSION-FILE | ||