diff options
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r-- | plugins/Makefile.am | 23 |
1 files changed, 18 insertions, 5 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am index a6c0ba65..04fb7ed2 100644 --- a/plugins/Makefile.am +++ b/plugins/Makefile.am | |||
@@ -27,7 +27,7 @@ MATHLIBS = @MATHLIBS@ | |||
27 | #AM_CFLAGS = -Wall | 27 | #AM_CFLAGS = -Wall |
28 | 28 | ||
29 | libexec_PROGRAMS = check_apt check_cluster check_disk check_dummy check_http check_load \ | 29 | libexec_PROGRAMS = check_apt check_cluster check_disk check_dummy check_http check_load \ |
30 | check_mrtg check_mrtgtraf check_ntp check_ntp_peer check_nwstat check_overcr check_ping \ | 30 | check_mrtg check_mrtgtraf check_ntp check_ntp_peer check_ping \ |
31 | check_real check_smtp check_ssh check_tcp check_time check_ntp_time \ | 31 | check_real check_smtp check_ssh check_tcp check_time check_ntp_time \ |
32 | check_ups check_users negate \ | 32 | check_ups check_users negate \ |
33 | urlize @EXTRAS@ | 33 | urlize @EXTRAS@ |
@@ -40,34 +40,46 @@ EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \ | |||
40 | check_nagios check_by_ssh check_dns check_nt check_ide_smart \ | 40 | check_nagios check_by_ssh check_dns check_nt check_ide_smart \ |
41 | check_procs check_mysql_query check_apt check_dbi check_curl \ | 41 | check_procs check_mysql_query check_apt check_dbi check_curl \ |
42 | \ | 42 | \ |
43 | tests/test_check_swap | 43 | tests/test_check_swap \ |
44 | tests/test_check_disk | ||
44 | 45 | ||
45 | SUBDIRS = picohttpparser | 46 | SUBDIRS = picohttpparser |
46 | 47 | ||
47 | np_test_scripts = tests/test_check_swap.t | 48 | np_test_scripts = tests/test_check_swap.t \ |
49 | tests/test_check_disk.t | ||
48 | 50 | ||
49 | EXTRA_DIST = t \ | 51 | EXTRA_DIST = t \ |
50 | tests \ | 52 | tests \ |
51 | $(np_test_scripts) \ | 53 | $(np_test_scripts) \ |
54 | negate.d \ | ||
52 | check_swap.d \ | 55 | check_swap.d \ |
53 | check_ldap.d \ | 56 | check_ldap.d \ |
54 | check_hpjd.d \ | 57 | check_hpjd.d \ |
55 | check_game.d \ | 58 | check_game.d \ |
59 | check_radius.d \ | ||
60 | check_disk.d \ | ||
61 | check_time.d \ | ||
56 | check_nagios.d \ | 62 | check_nagios.d \ |
57 | check_dbi.d \ | 63 | check_dbi.d \ |
64 | check_tcp.d \ | ||
65 | check_real.d \ | ||
58 | check_ssh.d \ | 66 | check_ssh.d \ |
59 | check_nt.d \ | 67 | check_nt.d \ |
60 | check_dns.d \ | 68 | check_dns.d \ |
61 | check_mrtgtraf.d \ | 69 | check_mrtgtraf.d \ |
62 | check_mysql_query.d \ | 70 | check_mysql_query.d \ |
63 | check_mrtg.d \ | 71 | check_mrtg.d \ |
72 | check_ntp_peer.d \ | ||
64 | check_apt.d \ | 73 | check_apt.d \ |
65 | check_pgsql.d \ | 74 | check_pgsql.d \ |
75 | check_ping.d \ | ||
66 | check_by_ssh.d \ | 76 | check_by_ssh.d \ |
67 | check_smtp.d \ | 77 | check_smtp.d \ |
68 | check_mysql.d \ | 78 | check_mysql.d \ |
79 | check_ntp_time.d \ | ||
69 | check_dig.d \ | 80 | check_dig.d \ |
70 | check_cluster.d \ | 81 | check_cluster.d \ |
82 | check_ups.d \ | ||
71 | check_fping.d | 83 | check_fping.d |
72 | 84 | ||
73 | PLUGINHDRS = common.h | 85 | PLUGINHDRS = common.h |
@@ -110,6 +122,7 @@ check_curl_LDADD = $(NETLIBS) $(LIBCURLLIBS) $(SSLOBJS) $(URIPARSERLIBS) picohtt | |||
110 | check_dbi_LDADD = $(NETLIBS) $(DBILIBS) | 122 | check_dbi_LDADD = $(NETLIBS) $(DBILIBS) |
111 | check_dig_LDADD = $(NETLIBS) | 123 | check_dig_LDADD = $(NETLIBS) |
112 | check_disk_LDADD = $(BASEOBJS) | 124 | check_disk_LDADD = $(BASEOBJS) |
125 | check_disk_SOURCES = check_disk.c check_disk.d/utils_disk.c | ||
113 | check_dns_LDADD = $(NETLIBS) | 126 | check_dns_LDADD = $(NETLIBS) |
114 | check_dummy_LDADD = $(BASEOBJS) | 127 | check_dummy_LDADD = $(BASEOBJS) |
115 | check_fping_LDADD = $(NETLIBS) | 128 | check_fping_LDADD = $(NETLIBS) |
@@ -130,8 +143,6 @@ check_nagios_LDADD = $(BASEOBJS) | |||
130 | check_nt_LDADD = $(NETLIBS) | 143 | check_nt_LDADD = $(NETLIBS) |
131 | check_ntp_LDADD = $(NETLIBS) $(MATHLIBS) | 144 | check_ntp_LDADD = $(NETLIBS) $(MATHLIBS) |
132 | check_ntp_peer_LDADD = $(NETLIBS) $(MATHLIBS) | 145 | check_ntp_peer_LDADD = $(NETLIBS) $(MATHLIBS) |
133 | check_nwstat_LDADD = $(NETLIBS) | ||
134 | check_overcr_LDADD = $(NETLIBS) | ||
135 | check_pgsql_LDADD = $(NETLIBS) $(PGLIBS) | 146 | check_pgsql_LDADD = $(NETLIBS) $(PGLIBS) |
136 | check_ping_LDADD = $(NETLIBS) | 147 | check_ping_LDADD = $(NETLIBS) |
137 | check_procs_LDADD = $(BASEOBJS) | 148 | check_procs_LDADD = $(BASEOBJS) |
@@ -158,6 +169,8 @@ endif | |||
158 | 169 | ||
159 | tests_test_check_swap_LDADD = $(BASEOBJS) $(tap_ldflags) -ltap | 170 | tests_test_check_swap_LDADD = $(BASEOBJS) $(tap_ldflags) -ltap |
160 | tests_test_check_swap_SOURCES = tests/test_check_swap.c check_swap.d/swap.c | 171 | tests_test_check_swap_SOURCES = tests/test_check_swap.c check_swap.d/swap.c |
172 | tests_test_check_disk_LDADD = $(BASEOBJS) $(tap_ldflags) check_disk.d/utils_disk.c -ltap | ||
173 | tests_test_check_disk_SOURCES = tests/test_check_disk.c | ||
161 | 174 | ||
162 | ############################################################################## | 175 | ############################################################################## |
163 | # secondary dependencies | 176 | # secondary dependencies |