summaryrefslogtreecommitdiffstats
path: root/plugins/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/tests/Makefile.am')
-rw-r--r--plugins/tests/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/tests/Makefile.am b/plugins/tests/Makefile.am
new file mode 100644
index 0000000..0d82be1
--- /dev/null
+++ b/plugins/tests/Makefile.am
@@ -0,0 +1,21 @@
1
2noinst_PROGRAMS = @EXTRA_TEST@
3
4# These two lines support "make check", but we use "make test"
5TESTS = @EXTRA_TEST@
6check_PROGRAMS = @EXTRA_TEST@
7
8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl
9
10EXTRA_PROGRAMS = test_utils
11
12LIBS = @LIBINTL@
13
14test_utils_SOURCES = test_utils.c
15test_utils_CFLAGS = -g -I..
16test_utils_LDFLAGS = -L..
17test_utils_LDADD = ../utils.o @EXTRA_TAPOBJ@
18
19test: ${noinst_PROGRAMS}
20 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
21