diff options
Diffstat (limited to 'plugins/tests/Makefile.am')
-rw-r--r-- | plugins/tests/Makefile.am | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/tests/Makefile.am b/plugins/tests/Makefile.am new file mode 100644 index 00000000..0d82be12 --- /dev/null +++ b/plugins/tests/Makefile.am | |||
@@ -0,0 +1,21 @@ | |||
1 | |||
2 | noinst_PROGRAMS = @EXTRA_TEST@ | ||
3 | |||
4 | # These two lines support "make check", but we use "make test" | ||
5 | TESTS = @EXTRA_TEST@ | ||
6 | check_PROGRAMS = @EXTRA_TEST@ | ||
7 | |||
8 | INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl | ||
9 | |||
10 | EXTRA_PROGRAMS = test_utils | ||
11 | |||
12 | LIBS = @LIBINTL@ | ||
13 | |||
14 | test_utils_SOURCES = test_utils.c | ||
15 | test_utils_CFLAGS = -g -I.. | ||
16 | test_utils_LDFLAGS = -L.. | ||
17 | test_utils_LDADD = ../utils.o @EXTRA_TAPOBJ@ | ||
18 | |||
19 | test: ${noinst_PROGRAMS} | ||
20 | perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS) | ||
21 | |||