Age | Commit message (Collapse) | Author | Files | Lines |
|
|
|
Update the THANKS.in file with the new Git commit authors.
|
|
|
|
|
|
check_ssh: check protocol
|
|
Include common.h before any system headers.
|
|
check_nt.c - Changed 'Mb' to 'MB' in MEMUSE.
|
|
Serveral coverity fixes from nagios-plugins
|
|
Signed-off-by: Sven Nierlein <sven@nierlein.de>
|
|
Added two if elses to cover when only one threshold is set.
|
|
|
|
|
|
will help the admins when multiple checks are configured
Signed-off-by: Davide Madrisan <davide.madrisan@gmail.com>
|
|
|
|
Coverity 66502 - File descriptor fd in cmd_file_read is never closed, and thus file is left open after usage throughout runtime. - SR
|
|
Coverity 66479 - validate_arguments has no need to return anything, as it dies on error, yet was set to return an int. Set to void to resolve warning.
|
|
Coverity 66480 - Potential array index out of bounds, since result was not verified to be positive prior to using as an index for state[]. Simply reording the if statement should resolve the issue. - SR
|
|
Coverity 66488 - offer_packet->options has a max size of 312. It was being used in a loop verifying less than 311, but increasing by 2 per loop, causing a possible array index out of bounds. Changed to checking less than max length - 1. - SR
|
|
Coverity 66514 - Possible leakage and overflow with addr in redirect functionality. Not confirmed as null terminated, and externally gathered. Restrict string comparisons and duplications by size. - SR
|
|
Coverity 66524 - req.data is not neccessarily null terminated but still feed to printf statements. This both does that, and verifies the struct more so than before. - SR
|
|
Recv into buffer is not properly null terminated prior to strstr and possible other string functions expecting a null termination. Simply take bytes received and use as an index to append \0 after. We are creating buffer[] with size of MAX_INPUT_BUFFER and recv with MAX_INPUT_BUFFER-1 so this should never overflow.
|
|
Coverity 66531 - ereg.buffer can be printed without being initialized if do_include and do_exclude are null and critical is an invalid regex. While minor this may leak memory and cause undefined behavior.
|
|
This should fix some problems building on AIX.
|
|
tests: always build and test on travis
|
|
also make test is now working on travis-ci
Signed-off-by: Sven Nierlein <sven@nierlein.de>
|
|
|
|
|
|
|
|
|
|
Add the new Git commit authors to the THANKS.in file.
|
|
|
|
Our die() function doesn't append a newline character to the message.
|
|
Prefer the FreeRADIUS Client library over radiusclient-ng, and prefer
that one over the original radiusclient library.
|
|
Allow for using the FreeRADIUS Client library instead of radiusclient or
radiusclient-ng. The latter two projects are dead.
Closes #1231.
|
|
The project was moved to SourceForge.net.
|
|
Add the UID of the invoking user to the state retention file path. This
helps solving permission issues when different users run the same
plugin.
|
|
NAGIOS_PLUGIN_STATE_DIRECTORY was renamed to MP_STATE_PATH, not to
MP_STATE_DIRECTORY.
|
|
Print a useful error message if opening the configuration file fails.
|
|
Read the configuration file with privileges temporarily dropped if the
code is used by a setuid plugin.
|
|
Our die() function doesn't append a newline character to the message.
|
|
Replace an "if" with the ternary operator.
|
|
|
|
Use Perl's FindBin module to locate the path to utils.pm in
check_file_age.pl and check_mssql.pl, just as we do in other Perl
plugins.
|
|
The puts(3) function already appends a newline character to the string.
|
|
Add two path names to the list of default INI file locations, as some
users/distributions prefer to put configuration files into
subdirectories.
|
|
We might want to spit out a warning when NAGIOS_CONFIG_PATH is used.
While at it, move the function that handles this environment variable to
the bottom.
|
|
|
|
|
|
Change the indentation and formatting of the code in lib/parse_ini.c.
This breaks patches against that file and makes it harder to track its
history, but it (hopefully) improves readability a lot.
|
|
There's no need to cast malloc(3)'s return value.
|