summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLorenz Kästle <lorenz.kaestle@netways.de>2023-08-28 13:16:30 (GMT)
committerLorenz Kästle <lorenz.kaestle@netways.de>2023-08-28 13:16:30 (GMT)
commit55c0e1738e3397b007ed189f216f8b431da96943 (patch)
treec033f29162569445495e379cc47e9a632d203b8e /configure.ac
parent70d0457562d58c16acd2a3514c9e4cc3f07ec923 (diff)
parentb90b09e1472426993d1c88949a8b30da3f2f900e (diff)
downloadmonitoring-plugins-55c0e1738e3397b007ed189f216f8b431da96943.tar.gz
Merge remote-tracking branch 'upstream/master' into fix/repair_test_pipelinerefs/pull/1907/head
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 069cc62..a294b00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,6 +328,25 @@ AS_IF([test "x$with_ldap" != "xno"], [
328 LIBS="$_SAVEDLIBS" 328 LIBS="$_SAVEDLIBS"
329]) 329])
330 330
331
332AC_ARG_WITH([systemd], [AS_HELP_STRING([--without-systemd], [Skips systemd support])])
333
334dnl Check for libsystemd
335AS_IF([test "x$with_systemd" != "xno"], [
336 _SAVEDLIBS="$LIBS"
337 AC_CHECK_LIB(systemd,sd_get_sessions,,,-lsystemd)
338 if test "$ac_cv_lib_systemd_sd_get_sessions" = "yes"; then
339 SYSTEMDLIBS="-lsystemd"
340 SYSTEMDINCLUDE=""
341 AC_SUBST(SYSTEMDLIBS)
342 AC_SUBST(SYSTEMDINCLUDE)
343 else
344 AC_MSG_WARN([Skipping systemd support])
345 fi
346 LIBS="$_SAVEDLIBS"
347])
348
349
331dnl Check for headers used by check_ide_smart 350dnl Check for headers used by check_ide_smart
332case $host in 351case $host in
333 *linux*) 352 *linux*)