summaryrefslogtreecommitdiffstats
path: root/plugins/tests/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2006-01-30 16:10:50 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2006-01-30 16:10:50 (GMT)
commit795100ae5124915bb647a304d5dfe2ada2f44ab0 (patch)
treeb3fd0dc1a88ebb533f074c476ee020e32877632e /plugins/tests/Makefile.am
parentc8a9bf228fdd34b021796f577a404cb8b0cba1f9 (diff)
downloadmonitoring-plugins-795100ae5124915bb647a304d5dfe2ada2f44ab0.tar.gz
Added libtap tests for utils.c library functions. Removed redundant
test files git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1303 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins/tests/Makefile.am')
-rw-r--r--plugins/tests/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/tests/Makefile.am b/plugins/tests/Makefile.am
new file mode 100644
index 0000000..0d82be1
--- /dev/null
+++ b/plugins/tests/Makefile.am
@@ -0,0 +1,21 @@
1
2noinst_PROGRAMS = @EXTRA_TEST@
3
4# These two lines support "make check", but we use "make test"
5TESTS = @EXTRA_TEST@
6check_PROGRAMS = @EXTRA_TEST@
7
8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl
9
10EXTRA_PROGRAMS = test_utils
11
12LIBS = @LIBINTL@
13
14test_utils_SOURCES = test_utils.c
15test_utils_CFLAGS = -g -I..
16test_utils_LDFLAGS = -L..
17test_utils_LDADD = ../utils.o @EXTRA_TAPOBJ@
18
19test: ${noinst_PROGRAMS}
20 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
21