summaryrefslogtreecommitdiffstats
path: root/plugins/tests/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2006-07-12 12:15:42 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2006-07-12 12:15:42 (GMT)
commitee03f1415acc9f4f8901593d9045244fbb3bbbb0 (patch)
tree32faccd0a0ac25373fec4823499969e62c2541ae /plugins/tests/Makefile.am
parentdf23fd75267c830f85a74cfde3020981c37e82a5 (diff)
downloadmonitoring-plugins-ee03f1415acc9f4f8901593d9045244fbb3bbbb0.tar.gz
Moving check_disk functions into utils_disk.c and testing them
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1447 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins/tests/Makefile.am')
-rw-r--r--plugins/tests/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/plugins/tests/Makefile.am b/plugins/tests/Makefile.am
index 8ed3fc1..741499d 100644
--- a/plugins/tests/Makefile.am
+++ b/plugins/tests/Makefile.am
@@ -7,9 +7,9 @@ check_PROGRAMS = @EXTRA_TEST@
7 7
8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl 8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl
9 9
10EXTRA_PROGRAMS = test_utils 10EXTRA_PROGRAMS = test_utils test_disk
11 11
12EXTRA_DIST = test_utils.t 12EXTRA_DIST = test_utils.t test_disk.t
13 13
14LIBS = @LIBINTL@ 14LIBS = @LIBINTL@
15 15
@@ -18,6 +18,11 @@ test_utils_CFLAGS = -g -I..
18test_utils_LDFLAGS = -L/usr/local/lib -ltap 18test_utils_LDFLAGS = -L/usr/local/lib -ltap
19test_utils_LDADD = ../utils.o 19test_utils_LDADD = ../utils.o
20 20
21test_disk_SOURCES = test_disk.c
22test_disk_CFLAGS = -g -I..
23test_disk_LDFLAGS = -L/usr/local/lib -ltap
24test_disk_LDADD = ../utils_disk.o
25
21test: ${noinst_PROGRAMS} 26test: ${noinst_PROGRAMS}
22 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS) 27 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
23 28