summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 24 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index bad5c53..a294b00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,6 +328,25 @@ AS_IF([test "x$with_ldap" != "xno"], [
328 LIBS="$_SAVEDLIBS" 328 LIBS="$_SAVEDLIBS"
329]) 329])
330 330
331
332AC_ARG_WITH([systemd], [AS_HELP_STRING([--without-systemd], [Skips systemd support])])
333
334dnl Check for libsystemd
335AS_IF([test "x$with_systemd" != "xno"], [
336 _SAVEDLIBS="$LIBS"
337 AC_CHECK_LIB(systemd,sd_get_sessions,,,-lsystemd)
338 if test "$ac_cv_lib_systemd_sd_get_sessions" = "yes"; then
339 SYSTEMDLIBS="-lsystemd"
340 SYSTEMDINCLUDE=""
341 AC_SUBST(SYSTEMDLIBS)
342 AC_SUBST(SYSTEMDINCLUDE)
343 else
344 AC_MSG_WARN([Skipping systemd support])
345 fi
346 LIBS="$_SAVEDLIBS"
347])
348
349
331dnl Check for headers used by check_ide_smart 350dnl Check for headers used by check_ide_smart
332case $host in 351case $host in
333 *linux*) 352 *linux*)
@@ -1592,13 +1611,13 @@ then
1592 grep -E -i "^lswap +path +pri +swaplo +blocks +free +maxswap" \ 1611 grep -E -i "^lswap +path +pri +swaplo +blocks +free +maxswap" \
1593 >/dev/null] 1612 >/dev/null]
1594 then 1613 then
1595 ac_cv_swap_format=[" %*d %*s %*d,%*d %*d %*d %f %f"] 1614 ac_cv_swap_format=[" %*d %*s %*d,%*d %*d %*d %lu %lu"]
1596 ac_cv_swap_conv=2048 1615 ac_cv_swap_conv=2048
1597 AC_MSG_RESULT([using IRIX format swap]) 1616 AC_MSG_RESULT([using IRIX format swap])
1598 1617
1599 elif [$PATH_TO_SWAP -l 2>/dev/null | grep -E -i "^path +dev +swaplo +blocks +free" >/dev/null] 1618 elif [$PATH_TO_SWAP -l 2>/dev/null | grep -E -i "^path +dev +swaplo +blocks +free" >/dev/null]
1600 then 1619 then
1601 ac_cv_swap_format=["%*s %*[0-9,-] %*d %f %f"] 1620 ac_cv_swap_format=["%*s %*[0-9,-] %*d %lu %lu"]
1602 ac_cv_swap_conv=2048 1621 ac_cv_swap_conv=2048
1603 AC_MSG_RESULT([using Unixware format swap]) 1622 AC_MSG_RESULT([using Unixware format swap])
1604 else 1623 else
@@ -1622,7 +1641,7 @@ then
1622 1641
1623 if [$PATH_TO_SWAPINFO -k 2>/dev/null | grep -E -i "^Device +1K-blocks +Used +Avail" >/dev/null] 1642 if [$PATH_TO_SWAPINFO -k 2>/dev/null | grep -E -i "^Device +1K-blocks +Used +Avail" >/dev/null]
1624 then 1643 then
1625 ac_cv_swap_format=["%*s %f %*d %f"] 1644 ac_cv_swap_format=["%*s %lu %*d %lu"]
1626 ac_cv_swap_conv=1024 1645 ac_cv_swap_conv=1024
1627 AC_MSG_RESULT([using FreeBSD format swapinfo]) 1646 AC_MSG_RESULT([using FreeBSD format swapinfo])
1628 fi 1647 fi
@@ -1631,7 +1650,7 @@ elif [$PATH_TO_SWAPINFO -dfM 2>/dev/null | grep -E -i "^TYPE +AVAIL +USED +FREE"
1631then 1650then
1632 ac_cv_have_swap=yes 1651 ac_cv_have_swap=yes
1633 ac_cv_swap_command="$PATH_TO_SWAPINFO -dfM" 1652 ac_cv_swap_command="$PATH_TO_SWAPINFO -dfM"
1634 ac_cv_swap_format=["%*s %f %*d %f"] 1653 ac_cv_swap_format=["%*s %lu %*d %lu"]
1635 ac_cv_swap_conv=1024 1654 ac_cv_swap_conv=1024
1636 AC_MSG_RESULT([using HP-UX format swapinfo]) 1655 AC_MSG_RESULT([using HP-UX format swapinfo])
1637fi 1656fi
@@ -1646,7 +1665,7 @@ if [$PATH_TO_LSPS -a 2>/dev/null | grep -E -i "^Page Space" > /dev/null]
1646then 1665then
1647 ac_cv_have_swap=yes 1666 ac_cv_have_swap=yes
1648 ac_cv_swap_command="$PATH_TO_LSPS -a" 1667 ac_cv_swap_command="$PATH_TO_LSPS -a"
1649 ac_cv_swap_format=["%*s %*s %*s %f%*s %f %*s"] 1668 ac_cv_swap_format=["%*s %*s %*s %lu%*s %lu %*s"]
1650 ac_cv_swap_conv=1 1669 ac_cv_swap_conv=1
1651 AC_MSG_RESULT([using AIX lsps]) 1670 AC_MSG_RESULT([using AIX lsps])
1652fi 1671fi