summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index e3b66fef..79b44c7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -607,23 +607,10 @@ dnl
607dnl Checks for header files. 607dnl Checks for header files.
608dnl 608dnl
609 609
610m4_warn([obsolete],
611[Update your code to rely only on HAVE_SYS_TIME_H,
612then remove this warning and the obsolete code below it.
613All current systems provide time.h; it need not be checked for.
614Not all systems provide sys/time.h, but those that do, all allow
615you to include it and time.h simultaneously.])dnl
616AC_CHECK_HEADERS_ONCE([sys/time.h])
617# Obsolete code to be removed.
618if test $ac_cv_header_sys_time_h = yes; then
619 AC_DEFINE([TIME_WITH_SYS_TIME],[1],[Define to 1 if you can safely include both <sys/time.h>
620 and <time.h>. This macro is obsolete.])
621fi
622# End of obsolete code.
623
624AC_HEADER_SYS_WAIT 610AC_HEADER_SYS_WAIT
625AC_CHECK_HEADERS(signal.h syslog.h uio.h errno.h sys/time.h sys/socket.h sys/un.h sys/poll.h) 611AC_CHECK_HEADERS(signal.h syslog.h uio.h errno.h sys/time.h sys/socket.h sys/un.h sys/poll.h)
626AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h) 612AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h)
613AC_CHECK_HEADERS_ONCE([sys/time.h])
627 614
628dnl Checks for typedefs, structures, and compiler characteristics. 615dnl Checks for typedefs, structures, and compiler characteristics.
629AC_C_CONST 616AC_C_CONST