summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d621ad6..cbc2f3c 100644
--- a/configure.in
+++ b/configure.in
@@ -601,7 +601,23 @@ AC_MSG_CHECKING(for ps syntax)
601 601
602dnl Now using the pst3/kmem hack for solaris systems to avoid truncation 602dnl Now using the pst3/kmem hack for solaris systems to avoid truncation
603if test "$ac_cv_uname_s" = "SunOS"; then 603if test "$ac_cv_uname_s" = "SunOS"; then
604 ac_cv_ps_command="pst3" 604 #
605 # this is a very, very ugly hack, to hardcode the location for plugins
606 #
607 if test "$libexecdir" = '${exec_prefix}/libexec'; then
608 if test "$exec_prefix" = "NONE"; then
609 if test "$prefix" = "NONE"; then
610 pst3="$ac_default_prefix/libexec/pst3"
611 else
612 pst3="$prefix/libexec/pst3"
613 fi
614 else
615 pst3="$exec_prefix/libexec/pst3"
616 fi
617 else
618 pst3="$libexecdir/pst3"
619 fi
620 ac_cv_ps_command="$pst3"
605 ac_cv_ps_format="%s %d %d %d %d %f %s %n" 621 ac_cv_ps_format="%s %d %d %d %d %f %s %n"
606 ac_cv_ps_varlist="[procstat,&procuid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]" 622 ac_cv_ps_varlist="[procstat,&procuid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
607 ac_cv_ps_cols=8 623 ac_cv_ps_cols=8