summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index dc3ee893..e41201c4 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -7,8 +7,21 @@ noinst_LIBRARIES = libmonitoringplug.a
7AM_CPPFLAGS = -DNP_STATE_DIR_PREFIX=\"$(localstatedir)\" \ 7AM_CPPFLAGS = -DNP_STATE_DIR_PREFIX=\"$(localstatedir)\" \
8 -I$(srcdir) -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins 8 -I$(srcdir) -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
9 9
10libmonitoringplug_a_SOURCES = utils_base.c utils_disk.c utils_tcp.c utils_cmd.c maxfd.c 10libmonitoringplug_a_SOURCES = utils_base.c utils_disk.c utils_tcp.c utils_cmd.c maxfd.c output.c perfdata.c output.c thresholds.c vendor/cJSON/cJSON.c
11EXTRA_DIST = utils_base.h utils_disk.h utils_tcp.h utils_cmd.h parse_ini.h extra_opts.h maxfd.h 11
12EXTRA_DIST = utils_base.h \
13 utils_disk.h \
14 utils_tcp.h \
15 utils_cmd.h \
16 parse_ini.h \
17 extra_opts.h \
18 maxfd.h \
19 perfdata.h \
20 output.h \
21 thresholds.h \
22 states.h \
23 vendor/cJSON/cJSON.h \
24 monitoringplug.h
12 25
13if USE_PARSE_INI 26if USE_PARSE_INI
14libmonitoringplug_a_SOURCES += parse_ini.c extra_opts.c 27libmonitoringplug_a_SOURCES += parse_ini.c extra_opts.c
@@ -16,4 +29,3 @@ endif USE_PARSE_INI
16 29
17test test-debug: 30test test-debug:
18 cd tests && make $@ 31 cd tests && make $@
19