diff options
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r-- | plugins/Makefile.am | 10 |
1 files changed, 8 insertions, 2 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am index e2bed4c3..04fb7ed2 100644 --- a/plugins/Makefile.am +++ b/plugins/Makefile.am | |||
@@ -40,11 +40,13 @@ EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \ | |||
40 | check_nagios check_by_ssh check_dns check_nt check_ide_smart \ | 40 | check_nagios check_by_ssh check_dns check_nt check_ide_smart \ |
41 | check_procs check_mysql_query check_apt check_dbi check_curl \ | 41 | check_procs check_mysql_query check_apt check_dbi check_curl \ |
42 | \ | 42 | \ |
43 | tests/test_check_swap | 43 | tests/test_check_swap \ |
44 | tests/test_check_disk | ||
44 | 45 | ||
45 | SUBDIRS = picohttpparser | 46 | SUBDIRS = picohttpparser |
46 | 47 | ||
47 | np_test_scripts = tests/test_check_swap.t | 48 | np_test_scripts = tests/test_check_swap.t \ |
49 | tests/test_check_disk.t | ||
48 | 50 | ||
49 | EXTRA_DIST = t \ | 51 | EXTRA_DIST = t \ |
50 | tests \ | 52 | tests \ |
@@ -55,6 +57,7 @@ EXTRA_DIST = t \ | |||
55 | check_hpjd.d \ | 57 | check_hpjd.d \ |
56 | check_game.d \ | 58 | check_game.d \ |
57 | check_radius.d \ | 59 | check_radius.d \ |
60 | check_disk.d \ | ||
58 | check_time.d \ | 61 | check_time.d \ |
59 | check_nagios.d \ | 62 | check_nagios.d \ |
60 | check_dbi.d \ | 63 | check_dbi.d \ |
@@ -119,6 +122,7 @@ check_curl_LDADD = $(NETLIBS) $(LIBCURLLIBS) $(SSLOBJS) $(URIPARSERLIBS) picohtt | |||
119 | check_dbi_LDADD = $(NETLIBS) $(DBILIBS) | 122 | check_dbi_LDADD = $(NETLIBS) $(DBILIBS) |
120 | check_dig_LDADD = $(NETLIBS) | 123 | check_dig_LDADD = $(NETLIBS) |
121 | check_disk_LDADD = $(BASEOBJS) | 124 | check_disk_LDADD = $(BASEOBJS) |
125 | check_disk_SOURCES = check_disk.c check_disk.d/utils_disk.c | ||
122 | check_dns_LDADD = $(NETLIBS) | 126 | check_dns_LDADD = $(NETLIBS) |
123 | check_dummy_LDADD = $(BASEOBJS) | 127 | check_dummy_LDADD = $(BASEOBJS) |
124 | check_fping_LDADD = $(NETLIBS) | 128 | check_fping_LDADD = $(NETLIBS) |
@@ -165,6 +169,8 @@ endif | |||
165 | 169 | ||
166 | tests_test_check_swap_LDADD = $(BASEOBJS) $(tap_ldflags) -ltap | 170 | tests_test_check_swap_LDADD = $(BASEOBJS) $(tap_ldflags) -ltap |
167 | tests_test_check_swap_SOURCES = tests/test_check_swap.c check_swap.d/swap.c | 171 | tests_test_check_swap_SOURCES = tests/test_check_swap.c check_swap.d/swap.c |
172 | tests_test_check_disk_LDADD = $(BASEOBJS) $(tap_ldflags) check_disk.d/utils_disk.c -ltap | ||
173 | tests_test_check_disk_SOURCES = tests/test_check_disk.c | ||
168 | 174 | ||
169 | ############################################################################## | 175 | ############################################################################## |
170 | # secondary dependencies | 176 | # secondary dependencies |