summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 30283cb4..04fb7ed2 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -40,11 +40,13 @@ EXTRA_PROGRAMS = check_mysql check_radius check_pgsql check_snmp check_hpjd \
40 check_nagios check_by_ssh check_dns check_nt check_ide_smart \ 40 check_nagios check_by_ssh check_dns check_nt check_ide_smart \
41 check_procs check_mysql_query check_apt check_dbi check_curl \ 41 check_procs check_mysql_query check_apt check_dbi check_curl \
42 \ 42 \
43 tests/test_check_swap 43 tests/test_check_swap \
44 tests/test_check_disk
44 45
45SUBDIRS = picohttpparser 46SUBDIRS = picohttpparser
46 47
47np_test_scripts = tests/test_check_swap.t 48np_test_scripts = tests/test_check_swap.t \
49 tests/test_check_disk.t
48 50
49EXTRA_DIST = t \ 51EXTRA_DIST = t \
50 tests \ 52 tests \
@@ -167,6 +169,8 @@ endif
167 169
168tests_test_check_swap_LDADD = $(BASEOBJS) $(tap_ldflags) -ltap 170tests_test_check_swap_LDADD = $(BASEOBJS) $(tap_ldflags) -ltap
169tests_test_check_swap_SOURCES = tests/test_check_swap.c check_swap.d/swap.c 171tests_test_check_swap_SOURCES = tests/test_check_swap.c check_swap.d/swap.c
172tests_test_check_disk_LDADD = $(BASEOBJS) $(tap_ldflags) check_disk.d/utils_disk.c -ltap
173tests_test_check_disk_SOURCES = tests/test_check_disk.c
170 174
171############################################################################## 175##############################################################################
172# secondary dependencies 176# secondary dependencies